Twrp for Zeblaze Thor 4 Pro (mt6739)

I have ported this twrp from this thread /thread/2966/twrp-iqi-i8-mt6739 to work with the Zeblaze Thor 4 Pro. It includes the boot.img from the stock firmware here /thread/3053/zeblaze-thor-4-pro-fw patched with magisk 18.0 and scatter file, Flash with sp flash tool and follow these instructions /thread/894/twrp-latest-boot-img-on
I have now received my watch and tested this twrp and im pleased to say its all working well so far, just renamed the twrp ing to recovery.img and the patched boot img to boot.img and flash using sp flash tools. I now have twrp and magisk on my zeblaze thor 4 pro :slight_smile: [/b]

Download Link-

1 Like

Maybe I will try later today

Update, now tested and working.

How is the Battery life Now?

I’ve only had this watch today but its lasted 7 hrs of constant use, screen on and playing music etc. I think having root and twrp bring a lot of opportunities as far as battery management but i havent had time to play around too much yet. I just wanted to test the twrp and boot img since i knew I’d posted it on here and wanted to confirm it working before trying other things
Edit, after using it today. The battery has proved to be much better than expected after seeing other reviews. Been using my watch from 8.15am til now 18.40, listening to music, answering messages and phone calls etc. Started fully charged and still have 39% left now. This is much more than I expected, ive seen others report only getting 4hrs. I am now hapoy this will last a full day to be charged overnight

Hello friend, I’ve tried to flash the TWRP recovery, spflash tools loads the scatter file, but when I press the download button, it says I have to load at least one rom, I tried to checkbox at least the recovery and boot.img, but it doesn’t allow me, so I’m stock! Is there another TWRP recovery?

Download the rom i have linked in the original post and replace and rename the patched boot img and twrp recovery img as described in the original post. Then load the scatter file from this rom in sp tools, make sure its set to download only, and have only the recovery and boot rows checked. This is how i did mine and its working perfectly. If you need any other help let me know :slight_smile:

I tried everything you said, and didn’t get any result, I don’t know what I’m missing!! Do you mind explaining step by step what I have to do, sorry for my ignorance! And thank you in advance.

Ok, I will try.
1/ download this rom
Then extract the zip and install the included sp flash tools (its apparently a newer version)
2/ Make sure you have installed vcom drivers, if you havent installed them, do a search and install them.
3/ download this Then extract the zip file and rename patched_boot.img to boot.img and recovery_twrp-20181231-1400.img to recovery.img.
4/Open up the images folder of rom you downloaded in step one and delete boot.img and recovery.img. Now copy the boot.img and recovery.img you renamed in step 3 and paste them in the images folder of your rom.
5/ Now open sp flash tools (the new one from step 1) and load the scatter file from the images folder of the rom downloaded in step 1.
6/ This should then load all the images available to flash. Uncheck them all apart from recovery and boot.
7/ Make sure its set on download only (you don’t want to format any unwanted partitions) then start the flashing process.
8/ Once flashing was completed i used adb command ‘adb reboot recovery’ and this booted into twrp. I then flashed magisk from twrp just to be sure, although this shouldn’t be necessary as i did already patch the boot.img with magisk.
9/ That’s it, then just reboot.

If this guide isn’t clear enough let me know and i will try to do a better guide with photos whilst i am sat at my laptop. I am about to get ready for work so don’t have time until later. I hope this helps

1 Like

I followed your guide step by step, downloaded rom, deleted boot and recovery, replaced them, changed names of the files, but when the spflash loads the scatter file, the boot and recovery row box are unchecked and empty, I click on them but they can’t be checked, I tried 3 versions of spflash tools,they all load the scatter file the same way, do you think it can be the TWRP folder with some problem? Or spflash?

1 Like

which scatter file are you using, the one from the stock rom folder or the one from the twrp folder? According to carolef1984s instructions you should open the one from the stock rom folder. I see that the scatter files are identical, so it should work as long as you have renamed the files that are in the same folder as the scatter file you’re using. It could also be that you haven’t renamed the files correctly. If you still can’t get it to work, you can try pressing the blank cell in the location column for both recovery and booth, then you can choose the files and they will automatically be checked.

I’m using stock fw with both original boot and recovery replaced by the ones from TWRP recovery, renamed boot.img and recovery.img. when i load the scatter file both recovery and boot are unchecked, I already tried to select them but nothing happens.

Ok maybe try the scatter file from the download twrp zip and see if that works. I will do the process on my laptop again after work to confirm and get back to you

Jan 14, 2019 22:55:36 GMT 1 cabeleira said:
I'm using stock fw with both original boot and recovery replaced by the ones from TWRP recovery, renamed boot.img and recovery.img. when i load the scatter file both recovery and boot are unchecked, I already tried to select them but nothing happens.

You have already tried pressing these fields and its not working?

Yes, it seems that the scatter file from the stock firmware zip isnt working. Here is a zip of the files you need already re-named. just extract this, select the scatter file from the extracted zips folder, make sure you are set to download only (no wipes) and flash. Just tested this and it works. Any problems let me know and i will help wherever possible.

Finally I got it done, I pressed those fields and could get the recovery and boot loaded, now I have magisk working, thanks to all of you, I’m very happy.

I rooted the watch. But now my battery life is shorter than before… What is the reason for that? I only install kernel auditor. I used before the zeblaze thor pro and there was the battery life better after I rooted the watch and installed kernel auditor.

My friend carolef1984, can you create the TWRP for the Zeblaze Thor 4 Plus model? I got the firmware link for that model!W4AU1ALB!PBGnwOorDo8MdrTpAyReTxjih3l47SLXmx4DF1YXG4k. tank you!


I have also a Zeblaze Thor 4 Pro, can you eplain how to install TWRP?
Above isn’t clear for me.

Regards haja.