TWRP For LEM8 and LEM7 withMT6739 chip

I have tried at least 6 methods to port TWRP recoveries from LEMX, Thor 4 Pro, and generic MT6739 and MT67xx chip recoveries into LEM7 and LEM8 recoveries.

I also used both rooted and unrooted LEM7 and LEM8 watches.

I used reboot apks to boot into recovery

I have tried fastboot flashing

I used SP tools to flash the TWRPS

Nothing worked

They both rebooted to the normal mode

I have concluded the following:

  • none of the TWRP portings worked, and/or

  • I could not reboot into TWRP recovery, or didn’t do it correctly, and/or

  • both watches are protected some way (fastboot shows the watches are locked and I cannot do a flashing unlock as the “yes” acceptance is hidden in the curve of the watch) and/or

  • I am useless (probably correct)

I note that there are several citations on this site that state that they have TWRP running on these devices.

If anyone has any ideas or can help, I will be grateful

You have to use the adb command “adb reboot recovery” after the watch has booted to system. On the rooted watches you will then get into twrp while on the nonrooted watches you will get into the stock recovery. There are several methods to ensure that the stock recovery doesn’t overwrite twrp:
Method 1: follow this guide to edit the boot image and flash it together with twrp:
Method 2: use magisk manager to patch the boot image and flash it together with twrp
Method 3: flash twrp at both the recovery partition and the boot partition(the watch will the boot directly into twrp). then from twrp flash the stock boot image and then magisk

Thanks for your reply. I will try the xiaomi method later to day.

I have already tried to flash with both the TWRP recovery and the boot.img patched by Magisk - did not work!

Also I previously tried adb reboot recovery and that did not work with either a patched boot.img nor rge stock boot.img.

With the stock boot.img it simply rebooted to the watch face and not into any recovery mode.

In regards to your Method 3, could you elaborate a little more as I am not clear as to what you mean i.e. flash twrp at both the recovery partition and the boot partition ?

Thanking you

I have managed to both root and install TWRP on the LEM8 and have posted the method elsewhere on this site. I had to start from scratch by reinstalling the stock firmware

However I am having trouble with the LEM7 (MT6739) as it keeps rebooting to TWRP.

Any suggestions anyone?

I will keep trying though!

1 Like