Ticwris Max doesn't see twin sim card

Hi, I’m a bit new in to this but I wonder if someone had the same problem as me. I have ticwris max 3x32 gb. It does work fine or sees normal sim cards. But it does not see my twin sim card (the sim card that has a clone that you get legally from your operator that tgey also call spare sim card in Turiksh, mine is vodafone for example but I had one from another operator of my country Turkey Turkcell too) The twin sim card doesn’t have any problem because it works with my other watch Lem 10 without any problem and Ticwris has no sim card tray ssues because it also works with any other sim card but the twin one. I flashed the rom, I even flashed lem T rom to my ticwris or even even I flashed lem 10 firmware to my ticwris, all seem fine except it does not see my twin card. Why can that be? Can anyone help?

No, it is not designed to use a twin Sim card.
I checked

Hi Pablo 11. How do you mean? Are you serious? My samsung gear s from 10 years ago was supporting it. My lemfo 6 was supporting it, even the 20 dollars smartwatch I’ve bought for my son supports it. I’m even using my second twin card in all of those and it is now inserted in my lem10. I dont mean a dual sim. It has to be a firmware error or a way of solving this

Ah I see.
I was thinking that you meant a type of dual Sim card.
You meant two cards, same number. One number two devices.
My apologies.
Then I guess it must be the APN settings in cellular settings.
Strange that it’s fine in the lem 10…

P.S.: After flashing LEM 10 and Lem T, now I’ll try to flash LES1, LF17 and Lem9V21 firmwares I found in Lemfo offical website to see if this solves my problem. (I, by the way, delete all an download in flash and does not seem to work. The watch has some other problems after flashing another watch’s firmware but still does not see the twin seem)

Yes, I ment two cards with same number, with same sim card I.D. Very strange thing indeed. I changed my carrier too. I thought Turkcell’s twin sim card had an error or a security measure and I bought Vodafone’s but nothing changed. I thought about IMEI problem and wrote the same IMEI that LEM 10 has to my Ticwris but nothing has changed. I wrote several times to ticwris customer service but they didn’t bother to answer. Can you think any possible hardware or firmware error for that?

Does it show any signal at all or completely unrecognisable?
I’m sure that you have checked the data is enabled etc etc…
If you have the ticwris and think it may be a brand problem you can always test by flashing the LEM T firmware. Just to test.

If it works with lemfo firmware then I guess it has to be APN settings

@Mercy1971 you should be using the firmware upgrade option in the flash tool.
Never format all + download.
Those other firmware files will not be able to work as they use a different chip and are mostly 3G.

If LEM T does not work nothing will… Firmware I mean.

Just compare APN settings that worked on the LEM 10 to the settings on this watch.

The only other thing I can think of is supported bands. Frequency bands

@pablo11, I’ve tested the LEM T firmware option but it didn’t change anything, I even tested the Lem 10 firmware with a small change on its scatter file. The watch started fine but it still didn’t recognize the twin sim card. It is completely unrecognisable so I cannot manually change the APN setting because it stays gray. And the APN settings when I insert the normal sim card of my son seem fine. But one thing though, at my first inserting the twin sim card, the watch worked fine for a few hours and then lost it’s signal and all this strange thing happened afterwards. That’s why I thouht the first twin sim card has a problem and changed my twin sim card with another carrier’s. I mean, when I unboxed it, for a few hours I had the twin sim card working but since then, not matter what I do only single sim cards work on it.

Try a Sim that you know is fine.
If settings are still greyed out it’s possible that you are not getting a proper connection from the Sim tray in the rear cover - to the board itself.
Unfortunately this means that the cover will need to be checked and probably removed to find out why connection is broken.
Obviously make a close inspection of the Sim tray connections first.
They are tiny little leaf springs and they can be bent out of place causing this problem you have…