SMS not being sent/received on LEM16

I can’t manage to send/receive SMSs with my LEM16.
It used to work on my LEM12 (before it died)
Any ideas? which app or what setting?
Thanks

You might be having some kind of problem with SMS Center. Check if you can access Phone Info menu using the following dial code on the Phone app: ##4636##. If nothing works, maybe someone else could assist you into checking some other way to trigger that menu.

If you are able to access Phone Info, its only a matter of asking your telecom what is your SMS Center number, write it on the number box and press “Update” (Write the SMSC into your memory) rather than “Refresh” (Checking your SMSC number from memory)

1 Like

Did you perform a factory reset when you received the watch?

I use Message by Google app and it’s ok with SMS or MMS, have you choose the right APN for your provider ?

Hi,
##4636## didn’t do anything.
What did you mean by:
"write it on the number box and press “Update” (Write the SMSC into your memory) "
Where should I write it?
Thanks

Hi,
No, I haven’t. I might resort to that if nothing helps
Thanks

Hi Christ,
I tried multiple apps including Google’s “message” but none worked.
It might be the APN although I copied all info from my phone.
Thanks

Yes, that’s what you should do. This might solve your problem.

Just finished Factory reset + reinstallation.
didn’t help.
I have a feeling it’s something to do with provider settings
Thanks

Where do you life? And what’s your provider?

Israel & Cellcom

Hmm, I’m not aware of any restrictions here. Does the SIM card work with another device?

1 Like

I have another Sim with same number in my phone where I do get SMSs
According to customer support, there might be a problem providing SMSs to both
although it did work on previous watch (with same Sim)

Yes, I suspect this is the cause of the problem. It doesn’t work with every device.

היי איציק,
Who is you provider?

Hi Sonia,
Cellcom

That what i thought i had same issue with them and now im with rami levi and all works fine.

5 Likes

Hi, I also changed the LEM12 pro to the LEM16, but I can’t get Spotify to work. Also, when the screen is square I can’t go back in an app until I exit it and go back to the app list. It’s a problem because I have to press the secondary button or switch to a circular screen. does anyone know how to solve it?

There are a few apps that ignores the back gesture in stock firmware. There’s no fix on that, just use the secondary button

1 Like

I installed the wheel launcher app, I chose the shortcut to start and now with two touches I can go back or exit the apps that do not come pre-installed on the watch.
Processing: 16717442114517718722985909452706.jpg…