Selecting notifications on my watch. Please help


I have just got and connected my prime 2 to my Samsung z fold 2.
Problem I’m having is every notification I get to my phone is going to my watch.
From emails to tic tok to facebook to Well anything and everything.

How and where do I select what I allow to be sent to the watch. As I only really want messages and text to be forwarded.

Thanks for any help

As far as the watch itself goes. Go to Settings/More/Notifications and disable all apps you don’t want to receive notifications from your watch. You didn’t mention which app you are using to connect your watch to your phone. I use Watch Droid and it also has a notifications function where you have to disable them. If you are set up on your watch to receive notifications from you phone you will also have to disable that option.

1 Like


I didn’t know I could connect via different ways. I think mine is connected via the default app. I think it’s wiiwear ? Does that make sense to you.

Yes. WiiWatch 2 is the default app. Watch Droid is another app used to connect the two devices. I prefer Watch Droid(WD) because it offers better features such as several options when responding to text messages from your phone, on your watch. I have used an older version of WiiWatch but never used WiiWatch 2 version so I don’t know what it offers.
The WD developer posts information on this forum. Search for Lumatic to find more information.

1 Like

Ok great thanks I’ll have a look.

Can I ask another question please. I have connected my phone to the watch and also the watch to the Internet WiFi. But the watch keeps disconnecting from the WiFi and when I click to reconnect nothing happens at all.
Have u had or heard of this ? And any idea how to connect so it stays connected to WiFi.