Screen lock by google mdm policy for android devices

Hi, I connected my KP2 to my company email address that is hosted by google (gmail). Then I was asked to secure watch by providing eg. custom PIN to comply with MDM policy. I also had some other possibilities that are normally used on a regular smartphone eg. a pattern to secure the watch. After I did setup this PIN my watch is locked with regular screen as it would be on a smartphone. I attach some photos of the screen lock. When I swipe from top to bottom like on regular smartphone I also have additional menu which is normally not available. As I couldn’t find in watch menus any way to turn this lock off I removed company email address from the watch. Unfortunately this didn’t remove the lock. Does any one know how to disable/remove this lock from the watch? I also tried to find this settings with some apps that show hidden settings but no luck here as well.

1 Like

Why can’t you put in the PIN that you set? If that isn’t possible, perhaps hold the power button for more than 10 seconds to reset the watch. Otherwise, you may have to reflash the ROM to remove the lock.

@pawgol If you know the pin and want to disable the screen lock policy then you should disable the device admin permissions for it first.
If you can’t get into the watch then @Tiggo is correct and you have to flash the firmware.

I know the PIN hence I wrote that I was trying to find this security settings with apps that show hidden settings. I’m aware that probably resetting watch to factory settings will probably disable this feature. However I’m trying to learn something new and I’m looking for some one who know how to do it without full factory reset.

How can I reach “device admin permissions”? I went through each and every menu in “settings”, “desktop settings” and “optimization” and I didn’t find any option to disable this security setting.

I am checking for you.
Give me a minute.
Also, when you look at Settings, about watch… Which version of firmware do you use?
V1.4 or 1.7…?

If you go to the watch Settings and then Optimisation, you can find screen lock settings.
Can you try to disable it from here?

It is not easy to disable this if this option does not work because the device admin permission is not accessible.

A full factory reset is best.

However, I have similar work security settings and normally if I uninstall the app, I get asked to disable this setting.
It’s usually email, for example.

Have you already tried to uninstall the app in question?

I cannot uninstall an app because this policy is probably built in in android and I do not have any additional app for it. Also settings for screen lock in optimization are different from the one that are built in android so I cannot disable it. (I disabled it previously because otherwise I would have two screen locks :smiley: like almost two factor authentication PIN + pattern)

So 1.7 is available? My OTA is still 1.4

1 Like

perhaps you can disable it using settings search app
this will open many settings unavailable in the default watch settings options.
usually lock screen falls in security options.

I wasn’t able to find those settings also using the app you provided. Security settings display only as below:

You said that you connected to your work email address.
I assumed that you had installed an email app, that is why I said uninstall it.
If you have disconnected from your work email and you have removed the account associated with your work then I would have thought you would be able to disable it.
If not, settings search won’t help and I think you will have to factory reset or flash the firmware

i have the same issue

is there a fix or a work around

Sorry, I must have misunderstood…
What is the problem that you have?

Have looked in app parameters, special access, then admin access ?

1 Like

Sadly I think it is not possible to access the device admin permissions on the watch.
I suspect that flashing or factory reset is best.
I will try to find out more but I can’t find anything so far

can not enter email info to set up account on watch settings search app is written for older version of droid

You can transfer this to your watch by USB and install it.
But as I said before, it does not seem to help access the device admin permission.

Settings Search_v1.0_apkpure.com.apk (136.0 KB)

You can flash the firmware in just a few minutes…
Much easier with these tools and read up about it of course.