Sad to report that my lack of patience has broken my D5.

Sad to report that my lack of patience has broken my D5. I like installing just about every watch face you guys post to see what it looks like on my watch. My routine is to disconnect from my computer after dropping new watch design folders into my ClockSkin folder on the watch, then touch and hold and scroll to the new skin thumbnail to take a look on the watch. I’ve always waited a couple of seconds between the disconnect and the press and hold to wait for reindexing the list on the watch. Last night I didn’t wait. Wrong.

Upon pressing and holding the watch screen immediately after computer disconnect, the screen went black. Scrolling left or right yielded nothing (I often get a black screen but scrolling reveals watch thumbnails between the black spacers). Tapping the screen again brought up an empty watch face (usually it’s the last watch face displayed if it was on a black spot when I tapped). I could scroll to the notifications, health, etc., but only black on watch face display.

So, I hooked back to the computer and deleted the entire ClockSkin folder. Same results upon disconnect. It’s like the clockskin indexing got corrupted and nothing is available.

So, in dismay, I rebooted the watch. It loaded through the logo to the short vibrate and slight screen dimming, then hung (presumably trying to load up the watch face index is my guess). Since it’s not fully booted, it won’t connect USB to computer. A long press on button reboots the watch, but same boot up to freeze happens.

So I opened and disconnected the power (glad I watched those SmartWatchTicks videos he he he). Reconnected, same result.

Pulled out the two screws to lift the top board a bit and shorted out center and one of the two side button connections and got the watch into some sort of recovery mode (I think – all Chinese), but didn’t know where to go or what to do. I tried to connect USB to the computer while in that mode, but no luck.

No, Lokie, I’m ashamed to say I don’t and didn’t TWIRP or flash or root or any of that stuff. I’ve always played with stock 'cause that’s where most of my video viewers are at. It’s the level I’m at, too. For now, all I can do is disconnect the power and wait for inspiration.

I’m posting this mostly as a warning to others to be patient when disconnecting after updating your ClockSkin folder before trying to switch watch faces. There’s something going on there, and it can be corrupted leading to catastrophic watch failure. A precious two seconds has cost me my watch (for now).

Sorry to hear of your troubles… will you be getting another D5?

Your videos have been an inspiration… thank you.

Sorry to hear that . I liked watching your videos very helpful

SmartWatch Ticks, to me has happened something like that. I accidentally delete the folder ClockSkin. Then I needed to turn off the clock and turn it on again (off and on), and the clock was not boot again, have stopped on the initial logo (he got the black screen without image).
Desperate, I just thought to flash again, and voila, problem solved. After creating the ClockSkin folder and put there some watches models, we can not delete the folder anymore. If we do, the clock does not start more. Only by flashing. Try and tell me if solve the problem.

SP Tools and flash a rom!

Agree with Sergio, should be able to flash stock back on it. download the kit from the No.1 site. (link below). Would suggest pulling the battery again and then plug back in and run the firmware update. Let me know if you need some help.
2016 Mar 10:
This firmware Fixed wifi MAC address aways change problem. aslo you can update through Wireless Upgrade in smartwatch itself.

Wow, thanks for the support everybody. You guys are great friends. Looks like I’m going to need to learn about SP Tools and flashing a ROM after all. Hey, If I finally understand it, I’ll try and do a video on it! I’m gonna set the D5 aside for a little while … 'cause … I got a new watch!!!

Yes Yes Yes! It’s a D5 cousin, the FINOW X1 and I’ve already set up a playlist to catch the upcoming YouTube videos. Once I knock out the obligatory unboxing and first look segments I’m going to rebuild it back like my D5 was before the ‘incident’ and keep moving forward. Again, thanks for your support. Made me feel a whole lot better. Here’s the new playlist link:

Oh, and for Lokie, no, didn’t have USB debugging on – although I wanted to – but I couldn’t do the plug and play thing for adding watch faces with it on. Since I’m messing with the ClockSkin folder a few times a day, switching USB debugging on and off was a pain. I wish I had it on, but I guess I need to learn flashing the ‘less than easy’ way.

looks just like the d5 . cant wait to see more about the finow x1 great video by the way.

@SmartWatch_Ticks ​ do yourself and your viewers a favor and learn how to flash, custom recovery, etc.

Since your D5 is already in a soft-brick state, you almost can’t break anything worse than it already is by learning.

We will make a flash addict out of Ticks before you know it. Once you go to the dark side you never come back Muahahah!!! (Dr. Evil Laugh)

You probably corrupted the memory the same way you can corrupt a USB stick if you yank it from your computer without un-mounting it. You may have noticed that you can’t select any custom watch faces if you are still connected to USB because the watch can’t access that memory while it’s mounted to the computer.
When you get your D5 up and running again you could use Airdroid (over WiFi) to copy files instead of USB. It’s safer and you can see the new clock skins while connected

We are waiting for your next video :slight_smile:

Had yesterday the same Problem but solved it without flashing.
But only because i have installed assistive touch some days ago and set it to autostart.
It seems that it is only a launcher problem, in assertive touch i clicked on favorites, added settings as favorites link and clicked on it . changed the watch face in the Clock Settings. After that everything works again. Someone who is in contact with the devs should write them, so they can correct this bug.