Rooting Kospet Hope

Disconnect the USB cable, power off watch, start SP flash tool and initiate the flash download, connect the watch USB cable, power on watch, and flashing will start. The very first time it can happen the driver does not complete installation fast enough. In that case repeat the process.

Feb 22, 2019 13:25:14 GMT jockyw2001 said:
Disconnect the USB cable, power off watch, start SP flash tool and initiate the flash download, connect the watch USB cable, power on watch, and flashing will start. The very first time it can happen the driver does not complete installation fast enough. In that case repeat the process.

Thanks, it worked fine, didn't need to start the watch after connecting it. The flash started directly.

Have anybody used the MTK Droid Tool with Kospet Hope or other android 7 watches ? I didn’t get it to work. I thought the drivers should be the same as for SP Flash Tool which connected without problems.

mtk droid tools doesn’t work with the newer watches

WwR_MTK_v2.30 and later seems to be the replacement for mtk droid tool.

Here you can find patched boot 27 Jan 2019:

There ia also the updated template.ini for WwR 2.40(added platform MT6739)

Feb 13, 2019 7:09:51 GMT RASC Moderators said:
Here is a patched boot and TWRP recovery for the Hope If you don't know how to use it - research it or don't use it. I would always reccommend patching the very latest boot image with Magisk manager but you can use this one if you want.

hi newbie here is it possible to root kospet brave ?

Hi, im rooting my kospet hope and have everything i need (all my files). Im in adb and fastboot. i have my oem unlock through developer but when i get to fastboot flash recovery patched_boot.img
target reported max download size of 134217728 bytes
sending ‘recovery’ (9910 KB)…
OKAY [ 0.825s]
writing ‘recovery’…
FAILED (remote: not allowed in locked state)
finished. total time: 0.826s

Plz Help

you should use sp flash tool instead of fastboot

I posted this. You never use fastboot on any MTK watches and you definitely don’t unlock the boot loader. These devices use preloaders.

You MUST use SP Flash Tools for this recovery and boot image.

What do we select in the SP Flash Tools to do this?
I already flashed [Hope_B_20190305] to my Hope.

Can i reflash it with that firmware using the patched boot file and the recovery.img file? I really don’t want to be stuck with a really old firmware. Though tbh i don’t even know if that’s the latest firmware.
Can i flash JUST the recovery/boot partitions?
I’ve never rooted using SP Flash Tool before. So i thought it was going to be like rooting my samsung galaxy on5 where i just need twrp, odin, and supersu.

Best to only root the other half. :slight_smile:

Norty norty… lol :joy::joy:

You should research it thoroughly first.
There is a Dev section here that explains how to do this.
Basically it is a simple case of flashing the boot and recovery image only. Then you install and run Magisk manager.
You need the stock firmware for the scatter file and in case you run into problems.

Well, this is the Rooting Kospet Hope thread. So i’m asking questions. Since there isn’t a lot of information regarding my specific questions that i can find on the forums or on google, that doesn’t point back to this thread.

I’m just wondering if i can use those Patched Boot and Recovery images on the Hope_B_20190305 firmware. Since it’s the only one i have and can readily download.

I’m not sure what is meant by “stock” firmware. If it’s the one that comes on the Hope from the manufacturer. They don’t all come with the exact same one. So mine might be newer or older than the one those boot/recoveries are made for. If you mean stock as the one that came on my watch originally. Well i already did a hard firmware update. soo… that’s long gone.

I’m trying to be specific with my questions, hoping to get answers specific to those questions. But it’s alright if you don’t know. Since maybe no one has tried doing this specific task.

I just don’t know if the recovery partition and boot partition(bootloader?) is firmware specific, or if they’re the same between firmware revisions.

You can usually mix boot.img with other build versions, however it’s not the best thing to do (you can lose new features, or existing ones can stop working). If you want, you can pull the boot.img from your specific firmware and patch it with Magisk on any Android device (even if it’s not rooted, just need to install the APK). Then, replace the “patched” boot.img with the newly generated one and follow the procedure normally.

Alright. I see what you mean. I see the boot.img in the updated firmware. This sound about right:

I’m assuming i can just copy that specific file over to the watch and “Magisk” it. Then copy it back and do a drag and drop into the 20190305’s folder and overwrite it.
Along with the patched recovery.img. I’m guessing recovery doesn’t need to be hacked again and i can use the one available in this thread’s gdrive.

And then just flash the hope again the way i did it the first time, but with the new boot/recovery partitions. Alright, i smell what you’re cookin’.

Late Edit: Can we flash JUST the Recovery and Boot partitions without flashing the entire firmware when doing this? You know, unchecking everything except those two?
And if we do, will it leave the rest of the data on the watch intact? I’d really rather not have to install all my apps again. Especially because i just got everything working again. :slight_smile:

Exactly, you can do that. If it’s easier for you, you can “Magisk” the boot.img in any android phone, it does not need to be the watch specifically.

As for flashing the images, yes, you can uncheck everything and flash just boot.img and recovery.img. Make sure it’s on “Download only” mode. You won’t lose any of your data :slight_smile:

Oh, almost forgot, yes, the recovery is completely independent, you can use any version that fits your watch model. Doesn’t matter what firmware version you are!

Tell me how it went!


Sadly, it’s a no-go. I made a new magisk’ed boot.img but they’re both giving me checksum errors.

Not sure if it’s safe to just run the checksum_gen.exe and then flash them anyways.

Edit: if i DO generate it. It moves the boot WAY down on the list. Not sure if that’ll mess up the data. Or if I’ll have to do a full flash, or what ever.

Not sure if that’ll break anything having it’s checksum changed and it’s position and order moved.

Just remove Checksum.ini and CheckSum_Gen.exe from the folder, restart SPFlashTools and it will work :slight_smile: