Request : root zeblaze thor 5 pro watch Or unlock the bootloader?

Is there anyway to root zeblaze thor 5 pro or anyway to unlock the bootloader , tried every method but no chance for real and am stuck here :frowning:

yes, you can root it. which methods have you tried and where have they failed?

Well i’ve tried using apps like kingroot and kingo root , tried with twrp for the same processor but bcz of the locked bootloader the watch don’t even boot if i put on it a custom boot patched with magisk or twrp
And i couldn’t unlock the boot loader bcz there is no volume buttons

yeah, kingoroot and similar doesn’t work, and magisk is better anyway. Did you patch the boot image with magisk yourself or did you find an already patched boot image for another watch?


I patched it myself , then before i flash it used the checksum tool with the firmware and flash it , when i open the watch it boot to zeblaze logo then goes black …. I think it’s bcz of the locked bootloader

I was reading everywhere and i found out that many had that problem when trying to root