QR code invalid for wiiwatch 2

Hello guys I am new to the site was recommended by Mr ticks from YouTube just a quick question I can’t seem to connect kos prime to the wiiwatch2 app…

When taking the picture of the QR code a message on the bottom of the phone screen tells me that the QR code is invalid can anyone help me with this.

Thanks alfie

You are talking about the Kospet Prime 1, I guess?

Sorry yes Kos prime se …

This is the first time I’ve heard of this problem. I think you can download it from the playstore too. However, I would recommend that you take a look at watchdroid instead. most of us here use it, you can also find it in the playstore.

I’m not too keen on watch tried to be honest I want something a bit better to keep track of my fitness goals… Can you recommend any

You should take a look at “myrunningApp”. But to be honest, @Dr_Andy_Vishnu is the specialist for this.

1 Like

I tried to download the app on Google drive but it said it did not exist anymore…has this been reuploaded again?

1 Like

Thank you Dr Andy so do I download this from Google drive on my SmartWatch and install it on there.?

Yes . It will work fine :+1:

You will need to turn on HRM settings in watch under sensors . Then turn it on in app

1 Like

I can’t seem to find the option for sensors in settings I don’t think the kospet prime se version has that?? Does it.?

-Settings
-more
-app settings
-app permissions
-body sensors

1 Like