Problem lemfo lem12

hello, thanks for accepting me in this forum. I have a problem with my lemfo lem 12, I try to connect it to the pc and it does not recognize it, it puts unknown usb, I have tried on several computers all with windows 10 and they all work out the same. I have reset the clock to factory values ​​and it remains the same, I have tried it with the cable and with the charging base and there is no solution. It only loads me but the pc does not recognize it, can someone help me, I have the latest version of clock rom 1.3. I hope you can help me. Thank you

Hi . Have you installed any drivers ?

If not they are in this folder

Install and reboot pc and watch

In watch also look in connection settings and select what you require


Thanks for answering, I have done what you have indicated but I still cannot connect the clock to the pc, unknown usb continues to appear and the usb option is disabled on the clock. any more suggestions ?? Thank you

Connection is hard to do on these watches, put the watch above the connector and let it sucks the magnets. Try also changing USB port.