Problem accessing the rear camera

I cannot access the rear camera on my Kronos Blade. When I touch the camera icon on the front camera the image inverts to upside down. I did a data reset without success. I then downloaded the firmware MT6739 and flashed the watch. I was able to access the rear camera–yaaah. But when I rebooted the watch I was no longer able to access the rear camera, only front camera image normal or upside down. I flashed firmware again and I was again able to access the rear camera but no camera icon on the screen to switch to the front camera. I rebooted again and the same front camera issue returned. So once more I flashed the firmware and this time I could not access the rear camera but still got the same front camera normal or upside down image. Now neither firmware flashing nor data reset will correct this problem.
Please help. Thanks

I am going to guess what you are calling the rear camera is actually the front mounted camera and the other is the left side camera or face camera. Also just to be sure which camera icon you are touching on the screen. This picture shows the three icons that appear on the screen. Shutter for Video and Camera and then the icon to switch from the front mounted camera to the face camera. Is this the icon you are touching? Make sure you are not accidentally touching the shutter icon for the camera.

Are you using the stock camera app that came on the watch or another camera app that you installed. If it is the stock app I would try another camera app such as “Open Camera” and see if it works better.
Open Camera

Also did you do factory resets after flashing the firmware?

Thank you for your response. I used the stock firmware to flash the watch after which I was able to access the rear camera (the one on the wrist strap). However, when I rebooted the watch I was no longer able to access the rear camera even after a factory reset. I tried to install the Open Camera app you suggested but Google showed it was incompatible with the watch. I tried to install many other camera apps without success. Surely, I’m not the only one to experience this issue. Is there another updated firmware to correct this issue?

I personally have not read of anyone having this particular issue. I have the Open Camera app installed on my watch and it works fine. Maybe your Google Play services app needs to be updated. Do a search on this forum for it.

1 Like