Prime SE firmware update

finally got an OTA for this 1.5. when i click install now it is stuck on 'Warning" screen about process and battery to be at 30%. i cannot visibly see ‘OK’ to tap. i have tried changing watch to round and square. Triple tap to zoom, Aaso tried moving 'Warning"screen but to no avail.
Any help please

It may help to reduce the font size or display size to be able to access the full screen. You need to gain access to the accessibility function on the watch. I use Setting Search app to do this. Search on this site or go to and you can find it there. Or try this link: Settings search

Long press the power button to force a reboot - it will be ok after that.
If it boot-loops then you had a partially installed OTA and you can flash the full firmware from the Prime main post.

1 Like

Thanks Jonathan.
That did the trick, although i could still only see ‘cancel’, i just pressed further to the right and must have clicked on ‘OK’, because it booted up fine.
Thanks for your help.
And thank you Pablo for advice.

1 Like