Pablo Eleven ​ The new firmware OTA for KW88 will do CPU throttling.

@Pablo_Eleven_Pablo11 ​ The new firmware OTA for KW88 will do CPU throttling. Does this mean the entire watch will work with a break on. What does this exactly mean? Live just checked and for my KW88 there is an OTA downloading. I’ve paused it. Will I have an option to opt out when it has downloaded or will it immediately apply the update?

Cpu throttling means it will set the cpu cores from low to Max as needed. This will result in lower power consumption for it powers down when ever it can and doesn’t need much cpu power. This can result in longer battery life. So overall this is a good thing. Please feel free to correct if I’m wrong.

Hi, I went to wireless update on my KW88 and I got a message saying “This version is not configured in FOTA server”. Do you know why is that?

@Martin_Nijhuis I know, and what you describe is a good scenario. But what if there’s no dynamic throttling and they just put a clamp on the cpu and keep it running at a fixed lower frequency? Whats the use then of a MTK6580?

Then you can flash back to the most recent firmware… Just don’t flash the userdata partition and you won’t have to reinstall everything.

@Pablo_Eleven_Pablo11 Thank god that’s possible, Is there a repository for the “old” fw?
I’m on the 29-7 non Plus fw.
And I assume you don’t know what type of throttling they applied? Dynamic or passive. My guts says passive.

To be honest I have no idea if it’s throttling they have applied but they said they have tried to address the reboot issue. My guess is it’s throttling they used. I would keep the update and use a cpu monitoring app to find out what’s going on.
The firmware is linked in the post I made about the OTA

@Kenneth_Tan did you already get the OTA? It’s not supposed to be released for another day or so …

This morning after reading your announcement I pressed update and it found one. Started downloading but because I didn’t know how far I could acknowledge the update I stopped the download. I was blindly downloading an update wothout any info on what is installed. No info given about the update. Not OK.

I just did the update and the watch came back up successfully. During the update, it spews lots of messages which is normally not a good thing but maybe it was resetting file permissions.

@Paul_Levy ​. Did at any point from detecting there’s an OTA to the finished update there was a point of no return where you get informed what was about to happen and what was going to be installed or was it there’s an OTA, you press download and no option until done?

Yes, you can check for the ota, then click to download it, then click to install it. Each step required a click. After downloading, it did not automatically try to install it. The other good news was that previously my watch would say the FOTA was not configured for my version so for those who also were seeing that, this update cleared that up for me.

@Paul_Levy I need the build date and info for this OTA asap please? King Wear are concerned because they haven’t enabled it yet. This means one of their partners must have released it without the green light from Kingwear.
FYI the company says that the watch will always report “not configured for OTA” when the service is turned off. A strange message to display but that’s it none the less.

missing/deleted image from Google+

Just tried to install OTA. Download worked, install failed.
Watch booted once, after firdt download. Then returned to launcher. Second try it did try to update, but ended in fail.
Rebooted from the recovery screen it landed in, and it returned to launcher. Firmware version was still the original. nothing happened. Have it all on video.
Third try reported “already at current firmware version”
Did they pull the update (the too early released one)?

I would not try that again until you get some word from @Pablo_Eleven_Pablo11 and KW. Especially since the main feature is throttling which I would say is there and causes my watch to wake up slightly slower than before.

@Paul_Levy ​ That’s disturbing news to hear that your watch starts slower. Is that a sign they applied a frequency clamp instead of dynamic cpu throttling?
I changed back to the original launcher today to do some ui tests, and the watch kept waking up every few seconds reminding me there was an firmaware update. It just didn’t shut up, so I decided to update and to film the update.

Well I think they changed the wrist gesture so it’s a bit slower to wake now. Pushing the button seems the same.

Thanks very much for your feedback guys. All reported back to KingWear by me today.
@Kenneth_Tan I believe your attempt which failed was due to you having a third party launcher selected when you updated…
I’ll let you know if I hear anything.

@Josue_Galindez do you have solution?