Pablo Eleven I had data connection on the x5.

@Pablo_Eleven_Pablo11 I had data connection on the x5. Does this mean I can’t now use this sim on the kw88?

the watch uses 2000 which in reality is 2100 so you should be fine

if you have no APN - this is the problem. Did you reset the watch?

@C_For you awake?

I checked through the KW88 apn list and EE is in there. Should be no problem for you mate. Try a reset.

@Pablo_Eleven_Pablo11 sorry only getting back now. I am using BT mobile (runs on the EE network) but the apn isn’t showing. T-Mobile is the apn listed in my settings (also on EE) I have tried editing the t mobile apn to the BT settings but not getting data.

These are supposed to be for EE

Enter the following data into the onscreen form, without changing any other settings:
Name - EE Internet
APN - everywhere
Username - eesecure
Password - secure
MMSC - http://mms/
MMS Proxy -
MMS Port - 8080
Authentication type - PAP
APN type - If given a choice, select internet+mms, if the keyboard appears enter *
(As a check, the image below shows blue text in the fields you should have completed)

@Pablo_Eleven_Pablo11 does the apn menu look like it is working ok on your watch? Can you edit and save an apn. I wonder does the loading logo mean it’s not working.

I have BT settings there now but still nothing. It’s really strange.

I am in Australia on Telstra network. But when I was in the UK EE worked fine on the X5. I don’t think you can even edit the APNs on this watch.

@Pablo_Eleven_Pablo11 so you don’t think there is a solution?

I think that when root and custom recovery becomes available you will be able to edit the apn config file and fix it. I have spoken King Wear about it but the problem is that there are so many re-sellers coming up that use different APNs - it’s almost impossible to stay on top of it. Did it work in your X5?

@Pablo_Eleven_Pablo11 Yeah it worked in my X5 no problem. I just added the APN and it was fine. When will root be available?

Looking in the IQI I2 thread and there seem to be guys that can edit their APNs. Have you had no luck editing yours at all? It’s basically the same software but different version…

@Pablo_Eleven_Pablo11 I can select it and type in it but I get that 14% loading screen overlapping so assume something is wrong with the menu. I have added them but no data and knowing that the BT sim is working on the EE network, I can’t understand why I can’t get a data connection unless something with the watch is up.

@C_For without screen shots of what’s going on I still think it’s APN related.