Originally shared by Edward Henry Lokifish Marz  I now realize you were talking about

Originally shared by Edward Henry

@Lokifish_Marz I now realize you were talking about waking the device with “OK Google” but here is the stock keyboard mic working on my X5.

Looks like you’ve set up everything very nicely… what’s the “toucher app” that you’re using?

How did you get the stock keyboard working? I’ve been trying to get this working for ages! What’s the launcher you are using also? Thanks

what is the app that you use to launch apps?

Does the OK google works from every screen or you have to touch the mic? Great launcher by the way, does it drain the battery?

@Andrew_Davis @sonia_sophie_ataunna @Diego_Torres @C_For The app that pops up from the corner is OmniSwipe, available in Play. The second screen is Floating Launcher 3 found watching @SmartWatch_Ticks productivity videos on Youtube. Just be sure to set OmniSwipe “trigger” in the apps settings to “middle right”.
The mic can be used on stock keyboard if you change the language tab (just to the right of the mic) to /EN or whatever your device language is set to, then be sure to “press and hold” the mic button while you speak your phrase/sentence.

unfortunately no it doesn’t work on any screen, but you don’t have to touch the mic to activate from the Google app itself.

@Edward_Henry Looks very nice… thanks for the info :slight_smile:

Well that’s very odd that it works for you. On mine it always says “Identification error. Network timeout” and always has done because the server used by the speech engine is Chinese. Which firmware version are you on?

@Pablo_Eleven_Pablo11 some who has the D5 got an update in April mine is as on no.1 site I have root but it doesn’t even says if there is an update and this keyboard also for me doesn’t work

I think this guy’s watch is an X5 - but still it doesn’t work for me and never has.

On any of them. Just doesn’t work and they all use the same code for this keyboard. It’s amazing watching the video and seeing it working :slight_smile:

for me even if it worked there is no hebrew on it so i can’t use it.

@Pablo_Eleven_Pablo11@sonia_sophie_ataunna ​ Yes it is the X5 and I am running 5/24 firmware ATM but it has always worked even with the initial firmware it came with (4/14 I think). All I did was during setup I chose English(US) as preferred language, then pulling up the keyboard, tap the mic key, speech window comes up, just to the right of the mic is a tab (#/EN), the default to the left side being a Chinese symbol thus connecting to the wrong server?, I tapped the EN side of that tab and it highlighted, it did take a few tries to get it to highlight though. Making sure I had a data connection (WiFi) I then press and HOLD the mic button while speaking. Good luck, hope this helps someone.

Yep mate, that’s what we’re doing as well. Tapping the EN on the tab to the right of the microphone always gives the network error and always has. For everyone except you that is and people who live in China. You must be blessed :slight_smile:

@Pablo_Eleven_Pablo11 Sorry to hear that, as this is such a necessary feature on such a small screen. Are you sure you have “Google voice typing” and “Speech Keyboard” selected in Language and input settings? Mine were not set by default and I had to do this. Also be sure PinyinIME is unchecked as well.

I do not have them both selected at the moment. Let me check that…

Ok, checked again and still the network error. Mind you I am using the April firmware. I’ll test again with the latest version.