Optimus Pro Clockskins

I definitely have searched the forums and YouTube and cannot find anything current on this topic.

I use the stock launcher (UL doesn’t seem to like my watch)

Is it possible to add third party clockskin to stock launcher? I see the clockskin folder in the watch storage.

Since Google + is gone, where do you get new clockskin?

I noticed that most skins that are available through the watch are simple analog without any extra data.
I have gone through the entire list of extra faces on the watch…

There are hundreds on this forum that will work . Most you will find are compatible , the ones under the " universal launcher " section may partly work . Watch our youtube video at the top left of main page . Really easy .

Look under " round android watchfaces " on main page . Right under your nose :grin:

1 Like

Hi! Can you explain why your optimus pro does not like universal launcher?

I was wondering, too. Because I know that it works perfectly in my Optimus Pro.


Really there seems to be only 1 issue. I’ve tried it twice. Even after a full reset.
The main clock is smaller than the screen size. The first time I installed it, the clock went edge to edge and then something happened and it resized to 3/4 screen size and I can’t change it.
Even after full reset, uninstall.

Maybe I’m doing something wrong.
Maybe it’s supposed to be that size now?

I just tried clockskin transfer and it says the clockskin has been installed and should be on the watch but I can’t find it. Long press and it doesn’t show up. Thoughts?
Edit… I just refreshed the clocks and it shows up now. Awesome! :joy:

1 Like

Your scale problem in UL is easy to solve:

  1. doubble tab the watchface
  2. move the red dot from the left to the middle
    (Scalevalue have to be 0)

Alright. Perhaps I’ll give it another try.
Thanks for the tip!

Strange. This time installed it was working properly. Was able to install a custom clockskin already.

Quick question… I am getting double notifications now that I’m using UL. I think I read something somewhere a few weeks ago about what to do…
I’m sure it’s a quick fix… Can anyone share?

1 Like

I never had this problem. I read about it also, there was an easy fix. But I can’t find the post atm.

1 Like

Alright. Thanks for checking on it. It only vibrates once but two notifications.

Try settings - more - appsettings - special access - notification access. Disable watch.


Thanks! Just checked and “watch” was already off. Looks like it’s only happening for whatsapp messages.

Just checked mine and @G1NT0N1C method works fine for me . No messages duplicated including whatsapp .

1 Like

Dear friends. My first Animation clock face. Modified universal launcher “Transparent” skin. Need it Universal Launcher. Kospet Optimus Pro dimensioned.
Download link : https://drive.google.com/file/d/1q83Rc3izHt9jXLei2ktKCQY4nFfByA6p/view?usp=sharing
Universal Launcher New gen v3.0 link : https://drive.google.com/file/d/1qXZ8pZFdHEca0fhwyQMgnmXfXlLzqfTX/view?usp=sharing

1 Like

Hi Guys,
I’ve been scouring the web (YT, this forum, etc) for days to find the exact same issue initially reported by Brandon (watchface doesn’t fill entire screen). I was disheartened, however, when noting that my scale is already set to zero. I’ve tried uninstalling and reinstalling UL, tried Eric’s “magic” button, tried removing and then reapplying watch faces, tried rebooting the watch, but no matter what I’ve attempted to remedy the issue I have not experienced success.
If I increase the scale I can get the watchface to fill the entire screen but the “edges” of the watchface are cut off. Is there anything else you recommend I try? I really want to give UL a go but will revert to the stock launcher if I cannot resolve this issue.

Have you tried to change from square- round mode? :wink:

Thanks for your prompt reply.
Yes, I’ve tried this. This just moves the face to the bottom left of the screen.

Ok, try the following: goto UL settings, tap “deinstall launcher” Then goto watch settings, uninstall aplications. Search watchclockskin. Tap on storage. Delete all data. Then uninstall watchclockskin. Then restart your watch.
Now install universal launcher again. Make sure that you are in round mode when you start the launcher the first time.

1 Like

Thanks for the suggestions but it had no effect on the issue. I realize that many people have UL installed and have no issue with their watchface so it has to be something I’m doing incorrectly.

Do you have “third party apps-adapter” enabled in watch Settings/More ?