OK I am close to finish the configuration of my finow x5.

OK I am close to finish the configuration of my finow x5. The only things that I’ve been having problems with are making calls from the watch (mobile network not available message), making Bluetooth calls from the swapp link app and I am having problems with the cycling apps I’ve been trying (strava, endomondo, runtastic). The problem is that it seems the app doesn’t recognize the GPS signal of the watch, so every ride I make is not recorded (only the length of time of it, but not the route nor the amount of kilometers). Hope you are still reading until the end of this post so you can help me. Thank you for all the help I’ve been receiving.

Can I use the swapp with zeblaze blitz ?
Also, I’m using runtastic and it works fine :confused:

I think so. +Jorge Fernandes. Great app by the way. I don’t know if there is something wrong with the watch’s GPS or it’s the app.

@Diego_Torres do I have to install swapp on watch too? Cause I can’t do sh** with it :c

Also, if you tried so many apps, it should be GPS watch problem :c

@Jorge_Fernandes you need it on watch and phone

@Diego_Torres try GPS status app from the play store. Go outside and clear agps in the app settings. Then update agps settings from the app.
You have to bear in mind that the GPS antenna is in the band of the watch and leave it outside until it gets a lock.
You also need to stop the connectivity being disabled when the screen is off. You can disable this setting in power saving options.

Are you trying GPS with mobile signal on or off? For me on KW88 GPS worked when mobile NW was on with data… (May be AGPS worked)

Yes - you need a sim card to get it working with data enabled.

I use this https://play.google.com/store/apps/details?id=com.protogeo.moves
You need to download and install from internal memory

sorry mate but I think we need to focus on getting his GPS working first. Thanks for the info though.
@Diego_Torres just realised that GPS status may be a little outdated now. Try GPS Test

@Diego_Torres I made it! Now i’m happy xb
@Pablo_Eleven_Pablo11 Thanks, it worked lke a charm !

@Pablo_Eleven_Pablo11 OK I will try it asap. Thanks everyone for the information. I think it could be the power saving option but I will try your solution.

Mmmmm could it be that I can’t make the mobile network work?

If your mobile data is not connected, it will not work.

That’s it… :frowning: I’ve been trying to use it as a phone but I can’t make it work. I tried and IMEI # and nothing.

You have no IMEI ?

you will need to contact @Jessie_Lin and ask for an email with instructions on how to fix this. It is against the law to publish this info publicly…

@Pablo_Eleven_Pablo11 how I do it? Do I send her an email? Thank for all your help

Yes - send her an email Jessie@finowatch.com