My watches are not connecting to my pcs.

My watches are not connecting to my pcs. I have tried opening them up and unplugging cable. I have switched computers 3 times, I’ve uninstalled/reinstalled the drivers and no luck (x5 (have 2), d6, s6, X0lS, and Q1. I can only get the the PTP, CDROM, and the Charger only sections to work on my s6/d6 and not the MTP. I was also having problems getting my Nexus 6p to open files, but resolved that issue today on Microsoft website. All 3 PCs have Windows 10 Pro and spouses computer has Win10. One of the computers is brand new as of today. Do you think Windows 10 put some type of block or total incompatibility on androids??? Any suggestions are well received!!!

I use Airdroid, but was using SP Flash for updating my firmware which is why I need to connect with a usb

Go to device manager with the watch connected. Go to update driver for the MTP or Android device. Click on "“browse my computer” then select “let me pick from a list of drivers” then if you are wanting to re-install the vcom drivers - they should be at the top of the list…

same thing happens to me.
The connect only the first time and could see in the Pc.
appears in the device manager but not the file browser.
It happens in I2

Yes…this is true.
Just use any BT app to transfer files or any other work around

Pablo, I tried that before coming here on all 4 computers. The only one that worked after I tried this was my Nexus 6P. If anyone finds the cure…drop a line.

First Note 7 sets us ablazed and now Microsoft has gone bonkers

I did, finally have my square watches working but not the round

@Splen_Dence I found I had to do this for every device sometimes. Which driver is the issue - MTP or the Vcom driver for flashing?

well, that’s weird. Using the alternative pre-installed driver as Loki showed works every time. I always select the last driver in the list and there are 3. I do notice that it needs to be done nearly every time I change device though. It’s not a once done you can forget it fix. Needs to be done over and over again…

doesn’t work at all, it maybe the chargers…I have 2, just ordered another one. I can’t tell but I think the 4th pin and the 3rd on the other are lower than the others (hoping thats the cause)

be interested to know :slight_smile:

Ok its definitely the chargers, I used tweezers to try to pull the pins up and was able to do a firmware upgrade on one of my watches but the pin won’t stay up,so one watch is better than no watch

there’s a guy on here who managed to buy pogo pins for next to nothing if you’re up for repairing… I think it was Kenneth…

I saw his post, I probably could combine the two that I have and fix to make one, while I wait for the other to arrive. I will try to pry it apart. Hopefully, will get both to work correctly again.

charger came in and only works on the 2nd x5, I still cannot get the first x5 to install original rom, doesn’t recognize MTP, but does for second x5. I can get into TWRP, but sideload gives me errors (not detecting device) no backup on twrp

thats not the problem, I’ve installed it quite a few times, I have several watches, but for some reason, this particular x5 is stubborn. I get a Microsoft failure msg when I attach the charger to the USB, but works great when I attached the second watch on the same charger. I’ve tried swapping the backs of the watches with one another and first x5 still doesn’t work. Me thinks it’s brickeddddddd

I enabled MTP on TWRP, and I switched computers, multi usbs no luck…I think I’ll let this rest for a bit and come back to it when I’m fully alert