My Prime stopped to count steps

Hi My Kospet Prime stopped to count steps, I rebooted it but the pedometer still does not work. What to do?

Are you sure pedometer is active in your system settings?

1 Like

I have the same issue. Fresh install of 1.6 firmware with factory reset. Pedometer service is enabled in settings but no steps counting. When I go in to MTK engineering and run the sensor test, like suggested on another thread, it shows that the sensor is working. It seems to be firmware related, not hardware.

Have you tried another pedometer application ?
UL for example?

1 Like

Not yet. Will give one a try and report back.

Interesting . Normally a full reset fixes this :thinking:

Eric, good tip. I used another pedometer app and it works fine so definitely software and something up with the native pedometer service. I will continue use the other app for now as it still shows the step count in the launcher. Thanks.

1 Like

So, check that your system pedometer is active in “gesture” setting menu.

Has always been enabled and have double checked + toggled on/off, still not working.