My KW88 suddenly start rebooting without any reason.

My KW88 suddenly start rebooting without any reason. I had it on my wrist all day, I didn’t install anything nor made any changes but it start rebooting nonstop. It vibrates once, shows the balloons page for about 5 seconds and reboots again. Once every maybe 20 or so reboots, it will get to the page that writes android but it reboots then. Has anyone seen this problem or know what I can do to fix it?

I also let it to run out of battery and then when plugged it to charger, it started the same reboot sequence.

Did you sweat a lot on your wrist the time it began to reboot?

Not really. I was in an air conditioned area. When I took it off my wrist, I inspected the back for the same but it was dry.

If any issue a boot could not solve,try a wired flash.

I need help with flashing it. Maybe I am missing something but I get below error, I hope some of the experienced guys here can shed some light on this.
missing/deleted image from Google+

I can see you tried flashing the preloader also…(hidden behind the error screen?

Everywhere here they tell you “DO NOT flash the preloader”

Don’t know what effect that had on the situation you’re in right now and if there is a way out for that?

Yes Martin, I realized that after the first time I tried it. I don’t know the impact of that.

Here is the new screen capture with the new version of the SP tool and the same error
missing/deleted image from Google+

I also noticed another thing, not sure if it is related. At the bottom of the SP tool it shows COM7 but my MT driver is on COM8, does it matter?
missing/deleted image from Google+

no it doesn’t …the pc is able to pick a free com port …as long as it is getting connection and flash indicator is running its ok.
Open the backcase of the watch …disconnect the battery, wait a while , reconnect the battery…the phone is now off. Open flashtool , open FW scatter file ,untick the preloader box, push download button, plug in watch via usb…done

Just went through the process of downloading each step one by one (excluding preloader of course) and I got green check mark for all but it failed on system with the same error. I think it fails to write to a block of the memory and then disconnects.

green check mark indicates all went well…I’m out of ideas then …sorry

Yeah, but I only got green checks for IK, boot, recovery, logo and secro. When I tried the next one which is system, it gave me the same error.

BTW, congrats on getting your watch fixed. Just saw your post. I also tried the process with the full tower size PC with no joy. I think mine has a hardware issue.

Anybody know if KingWear offers any sort of warranty?