My Kospet Prime USB connection not working

I started facing this issue after 1 month of using my watch. When i connect my watch to computer over USB, the USB setting is not getting enabled in the watch. So i am not able to transfer files over USB to the watch.

Is there any resolution for this problem?

It can be something simple as dirty connectors on watch or charging dock . Try cleaning with small amount of alcohol . I had this issue and this worked .

2 Likes

Does it charge OK? If it does you still may want to make sure the contacts are all clean and no pins are recessed. Does your computer respond at all when connecting the watch? Do you have other android devices which DO connect to the PC? Need more info to help. Windows? version? Do you have ‘Developer options’ enabled in the watch? Check USB options there if it is enabled.
If you have reset anything on the watch you may get a question on the watch asking if you want to allow the computer access to it with a checkbox. That only shows up briefly so if you don’t check that box it won’t allow transfers. But most likely it is related to what Dr_Andy_Vishnu mentioned - dirty contacts.

1 Like

Yes it charge OK over USB. I have cleaned contacts but no use. My computer used to respond to this watch earlier but now it is not responding. I dont remember that i reset the watch

connector and watch are not correctly aligned, try again, also try other USB ports…

1 Like

GA. Connect USB-Cable to USB-Slot on Computer. Shift on Watch-Screen to the left, select Data-Transfer out of Charging, DataTransfer and Foto-Transfer. Good Luck!
Hermann Schulze

1 Like

I am still getting same error.


I have tried resetting watch but no use.

Within this file is a " driver file " . Install on your pc , reboot and see if it works . Ignore the rest in folder . Let me know
Thanks