Mod of KW88?

Hello, since my watch didn’t include a camera, so isn’t “stock” of what a normal KW88 Pro usually is, I thought it would be best to ask you in private.

Which program do you recommend to alter the watch’s Android (or is that done via an .apk file)? I wish to delete the icon concerning the camera, as I do not intend to add a camera into the watch (I am not a tinkerer, just a technology geek). Where I work, doesn’t allow a camera inside the room I work in, anyway.

Hi, with root access, you can remove the camera app.

Thanks for the quick reply! I do have some root experience with a few prior Android smartphones, but I didn’t know the smartwatch could be rooted as well! As I mentioned in my first thread, I am not a developer, but I will trust the knowledgeable developers who have tested their work on their devices. With that said, I am a word person, so if the software developer sets up the code with a grammar mindset – not a programmer mindset – I could be dangerous, lol.

Back on the original question, I was hoping to have a professional set it up for me (so that I don’t “brick” my smartwatch). However, I’ll be more than happy to do so for myself, provided that there’s a backup ROM available, in case that I do change the settings incorrectly.

I did read another member mentioning sending the .apk to the smartwatch via Bluetooth; is that possible to alter the smartwatch’s settings via Bluetooth, or is connecting via the USB hardwire (laptop to smartwatch) the safest option?

You will need usb access to remove it via she’ll commands. There’s also some apps that use root to do it for you, I’m not an expert, so I put this public.

Hi. To remove camera app from smart watch use following commands.
From watch using Terminal Emulator:
su -c rm -rf /system/priv-app/WearCamera

From PC using ADB:
adb shell su -c rm -rf /system/priv-app/WearCamera

Or you can use special app with root access to remove system app.

Warning! Before make this operation, make backup first.

1 Like

I have my Smartwatch connected to my laptop via USB cord, but my laptop isn’t recognizing the Smartwatch, showing this error message: image I do have the ADB zip file saved on my laptop, and opened the Power Shell inside of the ADB folder. Please instruct with what are the next steps, thanks!

It’s usually due to a bad USB connection, just try several times, and also try other ports if possible. On kw88 you can also try to disconnect and reconnect the battery…

1 Like

powershell told you to use ‘.’ not ‘,’ apart from that, your last line looks fine

1 Like

I did notice that I had a comma, instead of a period. Here’s the updated results:

This is the tutorial which I am basing my process. On Step 5, does it mean to change the USB settings to MTP/File Transfer on the Smartwatch…or the laptop? If it refers to the Smartwatch, I cannot find where to change this setting; if it refers to the laptop, then the error in the screenshot above may be creating the issue. Possibly that is where the Power Shell error is created?


I have tried all 3 USB ports – twice each – on my laptop; all three give the same error. I even attempted to remove the charger from the watch and reattach it, to no avail.

I am extremely frustrated! I could Bluetooth or Wi-Fi the data from my laptop to my Smartwatch if all else fails. I did look into the Terminal Emulator, but seen some reviews from others that the security is vulnerable to being hacked. Maybe my best solution is to learn how to make my own .apk file and send it to my Smartwatch via Bluetooth.

have you turned on usb debugging in the developer options?

Yes, on the Smartwatch, It is selected. I don’t see where to select “MTP/File Transfer” on the Smartwatch; is that an option on the laptop USB settings only? If so, the black screen error above is preventing me from performing that action.

As for my idea to create my own .apk file, the service called Appy Pie seems to be aimed toward setting up a business based app and I don’t see where to input code for the Smartwatch, so I deem it as useless.

It’s usually the watch connection that is bad, so insist on this side.

It’s to be selected on the smartwatch, but you can’t do it before the connection is working

Thanks for the information! With that said, I don’t think the Smartwatch will allow a USB connection to this laptop. Therefore, I will have to rule out USB file sharing from my laptop to my Smartwatch.

Slightly off topic, but I did successfully get two different watchfaces sent to my Smartwatch via Wi-Fi with the app named “ClockSkin Transfer”. With this success, I could potentially send modified .apk files to my Smartwatch, or I could modify the .apk myself, with some instructions on how to edit an .apk file as I’ve not learned how to do editing yet.

Thanks again!