Lovely watch but usb data transfer not working

I have just received my kospet prime SE today, the build quality and screen are better than I had expected given some of the cases I heard about the optimus pro with broken plastic around where the straps connect, this doesn’t seem possible on this watch. I don’t actually own any other phone, this was/is intended to be my first phone since 2004 (long story as to my reasons) so connecting to my computer is the main way I intend to transfer data.

Sadly, I am having problems transferring files from my computer, either windows or macos, to my watch. It charges without a problem, bluetooth, GPS, wifi are also working perfectly.

If this is a hardware issue, could it be the dock? I’ve tried to clean the pins though they didn’t look like they needed it.

What else can I do? I really hope this won’t become an issue of sending it back as it will no doubt take a while for another to arrive. Do those sim card cables for the kospet hope work on these watches?

Connect your watch to the computer. Go to watchsettings- connect- USB. Chose data transfer.

1 Like

The option is greyed out, there appears to be no connection between the devices at all.

try to enable the debug usb in development options.

There are also apps to transfer files over wifi. The one I use is WiFi File Transfer Pro. There is also a free version but it limits file sizes.

1 Like

It doesn’t seem to make a difference? I’ve also tried cleaning the contacts with 70% alcohol to no effect. It looks like it is running firmware version 1.2 would it be worth doing a wireless update?

Wifi transfers I don’t think will be possible with this computer as I’m using ethernet, besides if I want to flash the watch later this would be problematic. There is a lot I like about this watch that I thought might be problematic such as the size, so I really want to solve this problem :smiley:

Cradle is not easy to use. What works better, is to put your watch above the cradle and lower it until it sucks the cradle. Then usually the alignment is better and you have the connection.

If your computer OS supports it (like Windows 10 does) you can set up a wifi hotspot for this purpose.

How so?

The thing is it is saying charger connected, which means the outer pins must be making contact. I’ve tried different usb cables as well now to no avail, as well as different usb ports. I’m just charging up an old tablet now to make sure I dont have multiple faulty cables or something :wink:

My computer doesn’t have a wifi card, I could possibly transfer files over bluetooth though but I imagine this could be very slow.

I would like to update the firmware at some point and/or root the device in the future. This appears very difficult/impossible over wifi from what I have read with an increased chance of bricking the device.

If this is a hardware issue and I have a problem with returning the device then I would be interested to see if the nano sim data cable that can be bought for the kospet hope works also with the prime?

I must already say thank you in advance for the quick community support/replies on here!

Sorry, but the data cable of the Kospet Hope won’t work.

Thanks for the quick reply.

Under device manager in windows I have “Unknown USB device (Device descriptor request failed)”, under macos I didn’t see if there was anything through command line but the usb option on the watch remains greyed out. Any ideas? I’ve tried deleting the device multiple times now, all the ports I have tried have been usb 3, maybe it will be worth moving the computer around to get to the usb 2 ports?

The dock is the cause!

I opened the back of the dock and noticed a design fault. The circuit board is apparently well secured but there is nothing supporting it underneath the board where the pins are. I’ve put a piece of rubber between the back cover and the circuit board and windows is recognising the watch every time flawlessly.

I will write on here again if the problem reoccurs but it certainly does seem the dock has a small but meaningful design flaw. This point should be made to all owners of kospet watches including if they have charging issues.

These watches are lovely and deserve to be maintained and used, it would be such a shame if people stop using them because of the docks.


very good job, buddy! I am glad that you recognized the problem and solved it. And thank you for posting the solution. This will help other members with the same problem.


please document your solution visually via uploaded images for the community to ensure further prevention and quick forum remedy search

thanks in advance and well done on the fix

1 Like

I’ve screwed the backplate of the dock back on but the screws are now slightly threaded so I didn’t want to take it apart again so I’ve drawn a diagram.

You can remove the bottom by first taking off the rubber ring from the bottom to reveal four screws, then remove the screws.

After this I simply stuck a piece of rubber under the circuit board where the connecting pins are above. the ideal is to create some pressure when the backplate is screwed back on. This is perhaps compensating for so kind of loose connection/soldering between the connection of the pins and circuit board but it continues to work perfectly.

The picture is a crop of a picture taken with the kospet prime itself :slight_smile:


much appreciated

Hi there, I just got a new Kospet Optimus pro. I wish I could transfer files to my MAC via the USB cable. I chose transfer files in USB connection (the option was available and was not greyed) but the MAC doesn’t seem to recognize the watch as being connected. The watch can be charged so the cable seem to work properly.

Thanks for help

Hi . Use this . I Do

Works 100% fine with no issues on my macbook

Thanks! I’ll try it.

1 Like