LEMFO LEM8 Battery Dead after 1 year

I bought my LEMFO LEM8 in November 2018 and have been using it every day.
Last week, the smartwatch seems to went dead in the middle of charging.
If I press the button for a long time, there is no response. The watch is cold, which suggest it is completely powered OFF. I tried charging it for many hours, still the same problem.
Does it mean I need to junk this watch? Any way of changing the battery?

Even if the battery is dead, you should ear a sound when plugging in the pc. If not, then it can be a cable issue.


If I connect the watch to the charging dock through the USB cable to connect to the computer, there is no sound, and the computer does not detect the existence of the android watch. This is very strange because if I connect other Android phones to the same computer, the computer can detect those Android devices and we can browse the Android device’s files from the computer.
I tried different USB cables and none of them worked.
Could this be an issue with the watch to charging dock connection? Or do you suspect other possibilities?

Get one of these or one like it to see what is going on…

If it reads O amps, but voltage is present, there is a connectivity issue.
The picture below shows a normally charging device…

1 Like

my Lemfo Lem8 doesn’t turn on neither charges anymore after overheating the battery for charging overnight.
If I connect to pc through usb cable windows makes the sound indicating a device has been connected, and the tester like that you suggested indicates 5V and 0,4 A a few seconds after the sound, then current gos to 0. How you can tell if it is a connectivity issue or a dead battery?

Thank you.