Lemfo Lem X please help with brick issue (resolved)

Hi,

I recently got the Lemfo Lem X and it was going well until I decided to install TWRP and try to root magisk on it. I tried following these steps here: /thread/2740/twrp-lemx?page=1&scrollTo=27316

One thing led to another, after I thought I followed the steps it didn’t let me get out of TWRP recovery boot. So, eventually I tried following the other steps which is to install the twro image after TWRP was installed and then the phone start saying “No OS installed” warning. After that, I tried to reboot my watch and now it’s always on and stuck at Lemfo. I can’t use the flashtool to go back into TWRP or use the adb tool to “adb reboot recovery” Anyone with experience know if this is fixable? I really love the phone and I usually root my other android phones well but I had a hard time with this watch and one button to work with. I would really appreciate anyone’s help in this area. Thank you.  

For now, the phone just stays on LEMFO and can’t even be turned off

EDIT RESOLVED Much thanks.

Oct 3, 2018 23:53:16 GMT 1 seyelive said:
Hi,

I recently got the Lemfo Lem X and it was going well until I decided to install TWRP and try to root magisk on it. I tried following these steps here: /thread/2740/twrp-lemx?page=1&scrollTo=27316

One thing led to another, after I thought I followed the steps it didn’t let me get out of TWRP recovery boot. So, eventually I tried following the other steps which is to install the twro image after TWRP was installed and then the phone start saying “No OS installed” warning. After that, I tried to reboot my watch and now it’s always on and stuck at Lemfo. I can’t use the flashtool to go back into TWRP or use the adb tool to “adb reboot recovery” Anyone with experience know if this is fixable? I really love the phone and I usually root my other android phones well but I had a hard time with this watch and one button to work with. I would really appreciate anyone’s help in this area. Thank you.

For now, the phone just stays on LEMFO and can’t even be turned off


Prepare SPFlashTools to flash the stock firmware and press on start, then connect the watch to the computer and press the power button until it reboots, then flashtools will recognize it and flash it to stock!

Thanks Iscle, I believe I followed your steps also and I was able to get back into TWRP recovery mode. But no matter what I do even following the steps to install TWRP image or install “TWRP_patcher.zip”, it mentioned an error and then says I have “No OS installed, are you sure you want to reboot?”. If I click reboot, it gets stuck at Lemfo logo. 

Sorry for the troubles, I thought the steps were easy but somehow I still mess it up. Any advice or suggestion for this fix?

Thank you

 

Nevermind, I believe I got everything to work. I’m still testing it but it looks like Magisk is installed too. I’ll play with it a bit and let you guys know. Thank you so much!

Oct 4, 2018 9:51:10 GMT 1 seyelive said:
Nevermind, I believe I got everything to work. I'm still testing it but it looks like Magisk is installed too. I'll play with it a bit and let you guys know. Thank you so much!

plz share what you did for others:)

I ran into the same issue if you figured out the solution I’d be most grateful, but side note I cannot mount the system partition either assuming the issue is one in the same. thanks

Hi, sorry just saw this message.

I posted in the TWRP Recovery Lem X section about what I did to fix it. I’ll copy and paste it here:

“Everything working really well now. I ended up flashing it back to factory reset to start all over, but I think the problem was after I install the patcher.zip, I install the twrp_image file and every time I did that, it did something to the partition and the OS, it removed the OS somehow. I skipped that part and just installed Magisk after I installed the patcher.zip. Now everything working very smooth.”

So if you got stuck like I did, first flash Lemx back to original state. There is a zip file here: 20180830 download = drive.google.com/file/d/1GbKrtEBSZYvxVIjQsDv3oWHl8n-8fM-u/view?usp=sharing

Once you download that, unzip it.

Step 1) Go into flash_tool, change Scatter-loading file to: MT6739_Android_scatter from the unzip 20180830 file located under the image folder.

Step 2) Just like before, click Download button and let the watch run the download to wipe fresh and install back to factory reset.  (THIS WILL INSTALL WATCH BACK TO NORMAL, like brand-new after you finish this step).

Step 3) [from /thread/2740/twrp-lemx ] - Provided by iscle and RASC Moderators.  IMPORTANT TO IGNORE the other steps from the top basically the steps about "If you have TWRP installed already"*

BUT START HERE!:
If you don’t have TWRP installed:

  1. With your watch turned on, copy the file “TWRP_patcher.zip” to the /sdcard directory.

  2. Turn off your watch.

  3. Open sp flash tool

  4. In the “Scatter-loading File” box choose the “MT6739M_Android_scatter.txt” file in the TWRP_image folder

  5. Press on “Download”.

  6. Connect the watch dock/cable to the computer.

  7. Put the watch on your dock/cable and wait until a green tick appears on the screen.

  8. Unplug your watch from the computer and power it on. It will automatically boot to TWRP.

WARNING: the following step (9) will install the default boot.img for the stock rom of the device. If you have another rom installed, be sure to flash it after finishing this guide.

  1. On the recovery, go to Install -> Install Zip and select the previously copied file “TWRP_patcher.zip”

  2. Wait until it finishes and that’s it!

Download TWRP for LEMX here drive.google.com/file/d/1F0uvm_7G_-rnRrHZcWAcKKqdmGZv3aW7/view?usp=sharing

ADB utility here drive.google.com/file/d/1Uz75C_KHBKkmssF_FRNlrS03B0vh9uON/view?usp=sharing

Step 4: Immediately install Magisk right away.

Step 5: reboot phone and it should work normally and be rooted with Magisk.

I hope that helps! It worked for me after few hours of testing lol.

Seyelive seyelive

I just want to say Thank you so much you rock my friend!!! Saved the day!

Have you installed the Xposed to see if it works?

I installed exposed framework via Magisk  and I think it is stuck at Boot Logo 0.0  not sure whats goin on xD rip lol

Edit: It just take a bit to load up but after it says remove battery because it’s over tempature D: ahh  options says snooze and dismess  should I be Worried at all?

Hi datastream,

I’m glad I was able to help. I did not install Xposed via Magisk, Magisk rooting after I install it was enough for me. May I ask why you need Xposed for?

I have been playing with the Lem X for 3-4 days now with Magisk root and haven’t run into any problems. I think someone posted their SIM card cannot be read with Magisk after a few days of use or due to things that Magisk is hiding. I am using SIM card and I think the only things I hide are playstore, google services framework and poke’mon go. Surprisingly, the game works really well on LemX haha.

I didn’t have any heating problems yet, unless I’m doing a lot of things on the watch like youtube, taking pictures, web browsing. Constant long use of the watch will heat up the battery and watch and that is normal. But if you do a few things at small period of times then no overheating problems. Is it possible that Xposed might cause heating problems? If things ever go bad, just factory reset like before and start again until you get what you want.

Dear bro,

After clicking download , I connected watch dock to the computer. But nothing happens. I think watch not connecting to computer.  For twrp flashing , watch should be in OFF mode … Right ?  
But in Watch on mode, watch asks for USB MTP transfer option, and connect with computer.  Please help.

Thanks.

Oct 9, 2018 1:39:23 GMT 1 seyelive said:
Hi, sorry just saw this message.

I posted in the TWRP Recovery Lem X section about what I did to fix it. I’ll copy and paste it here:

“Everything working really well now. I ended up flashing it back to factory reset to start all over, but I think the problem was after I install the patcher.zip, I install the twrp_image file and every time I did that, it did something to the partition and the OS, it removed the OS somehow. I skipped that part and just installed Magisk after I installed the patcher.zip. Now everything working very smooth.”

So if you got stuck like I did, first flash Lemx back to original state. There is a zip file here: 20180830 download = drive.google.com/file/d/1GbKrtEBSZYvxVIjQsDv3oWHl8n-8fM-u/view?usp=sharing

Once you download that, unzip it.

Step 1) Go into flash_tool, change Scatter-loading file to: MT6739_Android_scatter from the unzip 20180830 file located under the image folder.

Step 2) Just like before, click Download button and let the watch run the download to wipe fresh and install back to factory reset.  (THIS WILL INSTALL WATCH BACK TO NORMAL, like brand-new after you finish this step).

Step 3) [from /thread/2740/twrp-lemx ] - Provided by iscle and RASC Moderators.  IMPORTANT TO IGNORE the other steps from the top basically the steps about "If you have TWRP installed already"*

BUT START HERE!:
If you don’t have TWRP installed:

  1. With your watch turned on, copy the file “TWRP_patcher.zip” to the /sdcard directory.

  2. Turn off your watch.

  3. Open sp flash tool

  4. In the “Scatter-loading File” box choose the “MT6739M_Android_scatter.txt” file in the TWRP_image folder

  5. Press on “Download”.

  6. Connect the watch dock/cable to the computer.

  7. Put the watch on your dock/cable and wait until a green tick appears on the screen.

  8. Unplug your watch from the computer and power it on. It will automatically boot to TWRP.

WARNING: the following step (9) will install the default boot.img for the stock rom of the device. If you have another rom installed, be sure to flash it after finishing this guide.

  1. On the recovery, go to Install -> Install Zip and select the previously copied file “TWRP_patcher.zip”

  2. Wait until it finishes and that’s it!

Download TWRP for LEMX here drive.google.com/file/d/1F0uvm_7G_-rnRrHZcWAcKKqdmGZv3aW7/view?usp=sharing

ADB utility here drive.google.com/file/d/1Uz75C_KHBKkmssF_FRNlrS03B0vh9uON/view?usp=sharing

Step 4: Immediately install Magisk right away.

Step 5: reboot phone and it should work normally and be rooted with Magisk.

I hope that helps! It worked for me after few hours of testing lol.


Can you please give examples for any uses for root or Magisk on the Lem X?

I would also be interested in what you can do with the watch if it is rooted. I have rooted a lot of Android tablets, but do not see an advantage to rooting this watch.