Lemfo LEM T 1GB/16GB firmware

I flashed my Lemfo LEM T 1GB/16GB with a wrong firmware after which is doesn’t work anymore. I can still flash it though. I contacted Lemfo but didn’t get any reply to my firmware request yet.

So, I’m looking for a working firmware, stock or not, for a Lemfo LEM T 1GB/16GB smartwatch/phone.

Who can help me out here?

I can flash the firmware from Lemfo LEM 7 1GB/16GB after which it starts up but does not display anything. If possible, how can I implement the correct display driver? Or, how can I get the Lemfo LEM T 3GB/32GB working on the 1GB/16GB?

Lemfo still does not reply to my request for the firmware!

So you’ve already tried this fw on your watch ? and not working ?
if @pablo11 was available he surely could help, but with Australia’s fires, it’s not the time. Sorry we can’t help much.

Flash system image only and then factory reset might work.

Thank you @Eric_Crochemore for adding @pablo11 to this thread and thank you @pablo11 for your suggestion.

After flashing the LEM7 firmware I tried flashing the system image of the LEMTv1 and LEMTv1.4 firmware after which the device still boots up but have no display. I know it boots because I hear the start up sound. Tried getting into factory reset by holding both buttons on the LEMT but I don’t get into the menu because I have no display (stays black). Also looked at ADB factory reset but that does not work because I don’t get an ADB connection.

Any other suggestions?

As your watch is broken with the LEM7 fw, flashing the system only will not correct the issue. You need the LEM T firmware. So i ask again : have you tried it already ?

Sorry, Eric. I haven’t been clear on this.

If I flash the LEMT 3GB/16GB firmware the device does not boot into the android system. It keeps rebooting and does not show anything on the display.
If I flash the LEM7 firmware the device boots into the Android system. I hear the Lemfo sound and I get the lemfo ‘share’ in file explorer. The device display stays black.
In both cases I am unable to get into the menu to factory reset. ADB also does not connect.

I hope this answers your question.

1 Like

@Eric_Crochemore @pablo11

I got my Lemfo LEMT 1GB/16GB working again. :grinning:

I copied some files from the LEM7 firmware (LEM7-6739) to the DM100_LEMT_V1.4_20190919_P firmware overwriting the files in the DM100_LEMT_V1.4_20190919_P firmware. The files I copied are:

loader_ext.img
loader_ext_e1608.img
loader_ext_e1616.img
loader_ext_e3224.img
MT6739_Android_scatter.txt
preloader_C7S_e1608.bin
preloader_C7S_e1616.bin
preloader_C7S_e3224.bin
preloader_LD_C7S_AUO.bin

After copying these files I flashed the DM100_LEMT_V1.4_20190919_P firmware.

4 Likes

Unbelievable ! :+1::+1:

More like a miracle :joy::joy::joy:

2 Likes

good thing that it worked, but I wonder, did you try to run the file named sel_Size.bat before you solved it this way. I don’t know whether it’s working or if the developers just didn’t care to remove it, but if it is working then sel_Size.bat should have been able to solve your problem.

1 Like

@noidremained
Yes, I tried sel_Size.bat before doing anything else but that didn’t work. The device kept rebooting.
I also tried a lot of different things with all the files.
The file sizes of the loader files in both firmwares are different and both images use a different preloader.
I guess, copying the lem7 MT6739_Android_scatter.txt, preloader_LD_C7S_AUO.bin and all the loader files would be enough. I will try this later today and let you know.

1 Like

@noidremained

I looked a bit deeper into the files needed to get this working.

From the LEM7 firmware the following files are needed to be copied to the LEMT 3GB/32GB firmware to have it working for the LEMT 1GB/16GB:

loader_ext.img
MT6739_Android_scatter.txt
preloader_LD_C7S_AUO.bin

The scatter file directs to a different preloader, preloader_LD_C7S_AUO.bin
The loader_ext.img file from the LEM7 firmware looks the same, has the same size but is different.

Here’s the link to the firmware for LEMT 1GB/16GB

https://1drv.ms/u/s!Aub3vw3Kq5mlgqBK6ylAu9fF5gKAbw?e=pKMTkx

1 Like

I can’t say THANK YOU enough!!! I have the non LEMFO LEMT 16/1 and went thru the rooting shown in this forum and like you ended up in a black screen loop. I tried the 32/3 like you…nada. Your 16/1 saved my watch!!! If I could buy you a beer or? I’d do it!! YOU ARE THE MAN!!! THANKS AGAIN!!!

1 Like

May I too have a working link to this firmware package? I tried flashing my dm100 with the Ticwris Max firmware but the watch is stuck at the logo screen. Many thanks if you could help.

since the link doesn’t work anymore, you could try to assemble it yourself, the same way he did