Lemfo LEM 4 PRO Root Help

Hey guys…can anyone please help me to root my lem 4 pro watch ? I have tried but in vain…even info is not available on youtube or xda forums. Can someone make a video or a step by step procedure …sorry i am just a begineer …

Here’s everything you need to root it:

If you want you can verify the downloaded zipfile at deepvaultonline.com with the verification address Dp8dMXj7ZECznMgZeCDdJKPk5c8CPoqmkm


  1. Unzip the downloaded zipfile
  2. Find and open flash_tool.exe
  3. Click on the button to choose Scatter-loading File
  4. Navigate to and choose MT6580_Android_scatter.txt
  5. Press the download button
  6. Make sure your lem 4 pro is turned off and connect it to the computer
  7. When a green check mark shows up then it’s done
  8. (optional) Transfer MagiskManager-v7.3.4.apk to the watch and install it. When you open magisk manager it should say that magisk is installed
1 Like

Thanks for replying ! I followed your steps from 1 to 6 …after that flash tool gives me an error …what to do …?

what did the error message say?


This message comes as soon as i click on download and connect my watch in switched off mode. I am not getting the green check mark instead this error message is coming.

Should i first install magisk manager apk into the watch and open it and then follow the steps from 1 to 6 ?

you can try and see if it helps, but it shouldn’t make any difference

Can you do a video or upload images whenever you are free…thanks)

one more thing i noticed that the files you have provided boot.img file is missing …do you think that could be the reason for the error ? Instead magisk_patched.img is there …

should i enable OEM unlocking and USB debugging in the developer options before i switch off my watch and use the SP flashing tool ?

Thanks a lot bro …it worked ! Really appreciate your help ! :pray:

1 Like