Lemfo Lem 1/KW 98 problem

Hey guys i got a really cheap LEM 1 and it worked for the most part. The thing that did not work was when you let it go to sleep (10sec) it would shut off and needed to boot up again. I tried to reset its software in the settings and it worked but now when i boot up i have another problem.
When i select the language and put the data about weight and high, i get the menu to select if i want to connect to Android or IOS. Thing is when i select android and hit next it says (you have not changed the platform) and nothing happens. If i select IOS it wants to restart and than the same thing again. Its stuck in a loop. Is there a way to fix this?

I read about flashing the stock software however i have trouble with that.

This is the menu and error i am talking about.
Any help will be appreciated.

There’s no error there, it just ask the platform of your phone. If the choice is the previous one, it just say so.
For your boot loop issue, the best is to flash the fw again.

Thank you. I managed to flash the latest firmware and now it works like a charm.
I do however want to ask one more thing, when i bough it it was without the wristband.
Im having a hard time finding a wristband for it. Is it ok if i remove the two metal braces from it?
I know there is wires running trough them i assume about the sim card and GPS, witch i would give up in order to actually find a band.

It’s not too difficult to find a strap that will fit, you can look for example here:
and here:
I even found this one on amazon:


Unfortunately i live in Bulgaria so cant really order from these sites. Aliexpress is an option but i cant seem to find anything there.
I will try a few more places where they deal with watches, however many of them have only the standard wristbands.