LEM12 Pro A10 Official Support

There is. I want to try it. :slight_smile:
I installed the drivers, it can’t be started in any other way. The NEWS, PHONE, CONTACTS applications were more manageable in the original firmware. That’s why I want it back. I’ll get used to new things, but why not try comparing systems?

The flashing procedure is the same for all these watches . So choose a earlier version to flash if you want to . The forum is flooded with flashing tips and advice including a youtube video on our main page

Yes, on two comps, using included cable and some additional cable I have after other watches. The same results. I try to discharge a watch fully and let you know about results. Nontheless, I hear a silent voice inside, that chances are very low…

Believe me, it works in nearly any case.:wink:

1 Like

By the way, anyone tried to download watchfaces in any other way avoiding the pc-watch connection? By main motivation for that function is, that I want non-firmware clockfaces. It tried to download directly from cloud, but unable to unzip in proper folder. In fact, I have impression that unzip (or unrar) doesn’t work at all.

You can try


The playstore link for this app is down, but I can send you the APK tomorrow.

@nummatus, have you tried using the cable that connects directly to the watch and not through the power bank?

yes, it was my first try. Later I use powerbank

1 Like

Did you try installing the one click driver pack in my flash tools zip?
Also inspect the pogo pins on the cable.
They seem to be very unpredictable and can be a problem.

Using other pc with the drivers installed is also a good idea.

So today again test the battery. Yesterday at 7 p.m., the charge was 90 percent.
At 5.00 in the morning, the situation is 86 percent.
At 7.50 a.m. Activation of Sim and data. Nothing else. The battery saver is on all the time and three applications use unlimited data. The score is now 84 percent.
The time now is 12.50 pm. The watch had 3 calls and 4 SMS.
Battery status 74 percent. In 5 hours on the network and a total of about 17 hours. Good…
BT was active - handsfree. I recommend not using the “wake up by lifting” function.
It’s literally a battery killer

Hola Pablo,

I have installed those drivers. I even noticed, that there is MTK architecture indicated there, which is not, I believe, processor of Lem12pro (Quallcomm?). Up to now, the only result is that my computer went into “test mode” (little description in the right corner). This is not problem, as I know, how to remove it)

My pogo cable included seems to be ok. I tried cable and power bank as well. I tried also another four pins cable I own. (In sum: three separate connectors)

I didn’t install your drivers on any other computer (only my own), as the rest are either business device (company ownership) or Macbook. I was also misled by info somewhere at the forum, that win10 is problem-less with watch connection (no drivers needed).

I inform you if I solve problems today. Yesterday I was totally exhausted and “wkurwiony” (permit me not to translate that Polish word).

The only success of yesterday was idea of some benevolent soul on the forum, which prompted me his app to install watchskins via wifi. Unfortunately, I am unable to install some most valuable skins, where info about battery status and amount of steps are visible. “Clocksin transfer” can’t install them.

Well, to be fair there has been many reports that the drivers are not included in win 10.
But my preference is to use the MTK drivers…

You can always install Google drive on your watch for transferring files from your computer.

If you have no luck I can try to get you an update.zip to take you back to stock and then you can negotiate a replacement with the vendor you purchased it from.

Regarding windows 10 . I have a new windows 10 laptop . It originally worked fine with all watches ( no drivers installed ) then out of the blue stopped ? So then i installed drivers and it worked again . No idea why . In settings under usb connections is your watch set to " charging " or " file transfer " ? Just a thought …

1 Like

I have such a probably nonsensical question. I’m still at war with the “phone” and “messaging” applications. It’s too small for that display and it’s hard to control. Wouldn’t it be possible to get these applications from the original system into the unofficial firmware?

My experience with W10. I installed the drivers from the new Firmware and uploaded them to my watch. And the video started to chop on my computer, the garage didn’t work as it should and other things. So I reinstalled the drivers from the original Firmware. And everything works. I tried it again and the drivers really did

You install the drivers on your PC ? Not your watch . As for you garage ? You have lost me on this


Google mistranslated.
I installed the drivers on my computer. And then the problems with W10 started.

1 Like

You can find a very useful little program on the Web called USB deview.

It will allow you to roll back and fix any USB drivers in Windows.

However, be very careful using it.
It’s something you need to research before you use it…


1 Like