LEM12 Pro A10 Official Support

Seriously, we need people to use the search function under the banner of this website…
Everything (almost) has been discussed and isn’t this the whole point of having a forum? To share and learn from what has been done previously?

A quick search turned up many results and this is one of the first


Very sad to hear that you are having all those problems and also curious why others are not… :thinking:
But yes, go back to stock for now at least.

I will be posting an update tonight but I guess it is not going to help you.

By the way, this firmware is designed for people who use a Google account.
Are you signed in to Google Play and still have these issues?

And of course the obvious question - did you factory reset after updating the firmware?

Yes, I have a Google account and after installing the firmware I did the factory settings
I deleted the post because I didn’t insert it in its entirety. SMS works but I don’t see what I’m writing. It just doesn’t fit on the screen. In no mode. And when I use SIM, the battery consumption without BT, WiFi and data is about 15 percent per hour. Although I’m not calling. I solved the application crash by turning off the screen saver. Maybe that’s why consumption.

Thanks for the update :+1::+1:

Hello Everyone,

I just received Lemfo Lem12 pro. I faced some issues, which were absent in my former watches.

  1. It doesn’t synchronise with win10. A watch is loaded, but message from Win10 is that it is unrecognised device.
  2. It doesn’t synchronise my contacts with Google account, which was automatic in previous instances just after I register my google account in the watch. (Gmail seems to work properly, that is there are messages available on the watch as in the computer browser).

Could anybody diagnose those problems and help me if I should return a watch do vendor or are there solvable issues?

Great thanks

Hi . Read this post for the firmware you need

With windows 10 you shouldnt need to install drivers . However if you do they are in here

Hello again,

It seems flashing doesn’t work. I downloaded Flashing tools + firmware [Z32_Pro_30.04.21.7z] + manual. I went through the procedure to the last screen, and when I put a watch on the power bank, computer reported unrecognised devise and that’s it. There is no activity of flashing tool at all (no progress at the bottom).
Could you kindly interpret, what could it mean?

That also interested me. I tried to return the original firmware and it didn’t work. And not reinstalling the unofficial firmware either. I’ve always installed drivers. And the same problem as a colleague here. I know I’m wrong, but I don’t know what

Have you read this

Yes. Following this guide, I installed the unofficial firmware. After two days, it stopped connecting to windows 10. And I can’t reinstall the original system. But don’t even reinstall what I have in my watch. I just have a mistake somewhere and I don’t know where

I want to return to the original firmware, even if I reinstall the unofficial one anyway. I want to learn … I’m interested.

If you installed the firmware and it worked all should be okay . As for windows 10 have you tried installing the above drivers ? And dont forget after flashing Reset the watch to factory settings . There is no reason for you to try to flash to a previous firmware

It doesn’t help too. Morever, a procedure in manual is flawed. The sentence: “Click “ download “ then In the drop down menu change from “ download “ to “
firmware upgrade”, is impossible to execute, as after “download” menu start to be inactive. You can change the option into “firm upgrade” before you press download, but it also doesn’t work.

In summary, it is my forth watch and it seems simply broken, in a sense, that it doesn’t work. Any flashing is not possible, as computer immediately reports bad device, EVEN AFTER I switch a phone off. If I take into account my time consumed at fruitless efforts it seems it is highly unrecommendable divice.

Have you tried different USB ports? sometimes this is the problem. I once had a watch that had the same problem. The following trick always works with this watch: If you let the watch fully discharge before flashing and select the firmware update function, it will work in the vast majority of cases.

1 Like

There is. I want to try it. :slight_smile:
I installed the drivers, it can’t be started in any other way. The NEWS, PHONE, CONTACTS applications were more manageable in the original firmware. That’s why I want it back. I’ll get used to new things, but why not try comparing systems?

The flashing procedure is the same for all these watches . So choose a earlier version to flash if you want to . The forum is flooded with flashing tips and advice including a youtube video on our main page

Yes, on two comps, using included cable and some additional cable I have after other watches. The same results. I try to discharge a watch fully and let you know about results. Nontheless, I hear a silent voice inside, that chances are very low…

Believe me, it works in nearly any case.:wink:

1 Like

By the way, anyone tried to download watchfaces in any other way avoiding the pc-watch connection? By main motivation for that function is, that I want non-firmware clockfaces. It tried to download directly from cloud, but unable to unzip in proper folder. In fact, I have impression that unzip (or unrar) doesn’t work at all.

You can try