LEM10 sim card issues!

Hi all, first post!

Just received my LEM10, which seems like an awesome little device so far, except for one issue; it’s not detecting my nano sim card. I have inserted it according to the user manual, which is with the gold contact side facing upwards, and the corner notch going into the device. I’ll try to upload a photo.

Question: is there supposed to be a “click” like on some devices when the sim is inserted properly? I’ve tried using some force with my fingernail but didn’t want to try too hard. Have also tried rebooting, factory reset, etc. When I put the same sim back into my Samsung phone it detects it straight away, so I’m doubting it’s a sim issue.

Two pictures here showing the sim card “in” and “out” positions.

I’ve tried to contact Lemfo via email on their website but haven’t had a response.


I have a Lem 10 and never had this problem. To begin it requires a GSM Sim Card. In the US Verizon for example will not work. Only T-Mobile and AT&T. Sometimes on other watches I had to go into the Cellular Settings and manually enter the APN information that is available from the carrier. My carrier is AT&T but I use T-Mobile Sim Cards from Speed Talk but can use my AT&T Sim card, from my phone, if I wanted to.
I just realized you had two pictures available. It looks to me like the card is not inserted completely. For example will the door fit back normally. I should not require any pressure to install.

My curiosity got to me. I pulled the Sim Cover on my Lem 10 and my card inserted looks like your picture. The cover only goes back on only one way for it to fit properly. I double checked and my 2G service returned on T-Mobile. My last call on the watch, my daughter said it sounded good and she didn’t realize I wasn’t on my phone until I told her.

1 Like

I remember having this issue also at first. Then made sure I had inserted the SIM card properly and rebooted the watch after that. You may need to close it first so the screws are keeping it fully in place.

I am with Rogers in Canada and it has been working flawlessly.

Same here . This is the only watch i have had where i inserted the sim wrongly . As soon as i figured it was in upside down and needed the sim cover fixed for it to work correctly it has worked fine since .

1 Like

Hey, thanks for your reply. Found out the fix was to very slightly loosen the screws holding the case together, click the sim in, and then retighten. Your mileage may vary, but worked for me!

Hey there,

Thanks for the reply! I tried every possible physical way to insert the card, replacing the cover with the screws, etc, but it would still not “click” in place and recognise the sim.

Then I had an idea; maybe the watch case was too tight. I very slightly loosened the four screws holding the case together (like maybe a quarter turn each) and presto! The sim now clicks in perfectly and the the sim is now picking up my network and is fully functioning. So, little PSA out there if you experience the same issues - your case could be slightly too tight! I retightened the screws after the sim was in so as not to compromise the ip rating.