Lem t/ticwris max font size

I recently flashed a LEM T to TICWRIS firmware, expecting the Pulse SMS app installed on both, to have the same font size and readability, with the same font size selected in the Pulse app.

However the upgraded LEM T has a smaller font size, hard to read.

What else controls the overall display font size?

I’ve researched this a little bit farther and believe I’m getting closer to understanding what may be the problem. The other thing controlling the font size may be the Linux system.

Pulse SMS an Android app appears to just be scaling (4 scale factors) a base font possibly set by the basic Android or Linux system. This base font appears to be smaller in the LEM T flashed to TICWRIS, than it is in a factory fresh TICWRIS. The scaled fonts of the LEMT/TICWRIST end up being very small and unreadable. Has nothing to do with watch faces.

So I just need to learn how to change this base font, or get Pulse to add some larger scale factors.

with settings search you can find the font size setting under accessibility

1 Like

Thanks, that let’s me get at the accessibility settings , with 4 font size settings, but it didn’t work for the Pulse SMS app.

Pulse also has 4 font size settings which seem to just be scaling a single system font. I suspect the Pulse app simply overwrites the accessibility setting. I feel the base font size may be controlled by the linux OS and the Android functions and apps simply scale it. I may need to gain access to the Linux in order to fix it.

What I dont understand is why the flashing to TICWRIS system.img did not set it to be the same size as TICWRIS. Should I have flashed more than system.img ?

1 Like

However, accessibilty let me turn on the triple tap zoom, which does make the letters readable by my old eyes.


Does anyone know if flashing an original LEM T to TICWRIS firmware (system.img only) also increases the display resolution from 640x380 (LEM T) to 640x480 (TICWRIS) thus increasing the pixel density value?

I believe I’ve solved this problem. Getting no good answers by searching or otherwise, decided to go for broke. I reset the device, erased all data, started over, reinstalled Pulse SMS. This seems have worked. Pulse now uses full display area and fonts are readable.

1 Like