Kw99 pro / all call w1 firmware flash file

which part do you think?

Not sure what you are talking about? Use “download only” . Do NOT use “format all and download”.

i have a problem image

when I click the scatter file from flash tool

I can’t check the file at the moment, sorry.

1 Like

Tell us what firmware you had originally.

Was it Android 7 or Android 5?
AllCall W1 is 2+16 and that’s what you asked for.

The one I have just linked might work but there are many types of kW 99 so it is not easy to help without much information.

I hope you have taken the time to read up on how to flash firmware.
There is no need to have all these issues if you do your homework.


1 Like

android 7.0
I am sorry I meant 16+1 kw99 pro it’s similar to the all call w1 though.
another question should I turn off the watch or its ok t be on?
because every time I power it off and connect it to my laptop it powers on again.
and thank you for helping me

I flashed the watch
the watch still reboots.

That’s what I expected. I think it’s a hardware issue. Try to send it back to the seller to get a new one.

1 Like

That watch is no longer available and I am guessing you have had it for a while right?

Did you try to flash Asteroid or Openwatch firmware on it?
This is usually the cause of the problem.

It sounds like the boot loader is incorrect or corrupt.

You can use firmware upgrade option in the flash tool and see if it helps.

Definitely do not use format all + download

I had it for a month now and I will try to send it back
I did chose download only on the sp tool and it was the first time for me to flash the watch I didn’t flash it before

Use firmware upgrade option.

So this just “suddenly happened”
You didn’t flash anything to make it bootloop?

If you have only had it for a short time, I am wondering how this is possible unless it was used already?

KingWear stopped making this model almost 2 years ago :thinking:

1 Like

yes you are right

no, I didn’t

with the same process right?


I did it but the problem still exists.

I found out something every time I connect to the network it restarts and when I’m offline it doesn’t.

FAINALLY I found out the problem
the problem was from my network every time I connect to my wifi the watch keeps restarting but when I tried to connect by my mobile hotspot it worked fine so I think the problem is from the router, not the watch
IDK why this happens to my watch specifically but if anybody has any solutions please help me.

Check the router is set to WPA2 and not WPA3.

Remember that the watch board is very old and cannot support many settings on modern routers.