KW88 Pro firmware with ADB enabled?

Hoping someone here can give me a hand making something useful out of my KW88 Pro.

Long story short, I received this device as broken by someone who no longer cared to deal with it. In taking a closer look at it, it seems to be a defective display… when powered on, all that can be seen on virtually any screen are horizontal lines. I’ve tried re-seating the two ribbon cables that go to the display assembly, but still no luck. I have NO idea what version of the OS / firmware it has running on it now (it is a 1 + 16 hardware configuration), but I can tell it boots all the way up by the audible tones, and by seeing things “changed” on the screen when swiping / tapping after it boots.

So, the request… Is there any trick to enable ADB on the device without being able to see what is on the screen? Or maybe even better, a firmware image that has ADB pre-enabled? I’d love to get this enabled, because then I can think of a few uses for it, regardless of whether it has a working display or not.

Any assistance greatly appreciated!

Seems like the lcd panel is broken (I had a similar problem with a phone earlier, had to ditch it as the price for repairing was too high…here’s hoping your case won’t be like that)
I couldn’t find any replacement panel for the KW88 online, try searching for that
As for adb and usb debugging, try this:

  1. Extract the stock boot.img using this tool by Carliv(Thanks to him! Very useful tool)
  2. Then go to ramdisk folder of the extracted boot.img and in there edit default.prop using Notepad++
  3. Add the following lines/change the values–>
    [color=#15ff00] ro.debuggable=1[/color]
    [color=#15ff00] persist.sys.usb.config=adb[/color]
  4. Repack the boot.img using image tool
  5. Flash the boot.img using spflashtool
  6. Inform if it works :slight_smile:
1 Like

Thanks so much for the response! I had left the watch at my office, and just today had a chance to take a look at it again. Using those steps with the Carliv tool (and with some tweaking in SP Flash Tool to match the new checksum), I was able to actually make this work to the point that the PC does see the watch as an ADB-enabled device! So a partial success.

The only problem at this point, the device is showing in ADB as “unauthorized”… which I assume means it wants me to approve a dialog on the screen to allow ADB or something (as I have seen on other devices). Is there a way around this? Or can someone with a similar watch / android build give me a screenshot of how the screen looks with this dialog? (I believe my touchscreen works fine… I just can’t see where to click!)

Thank you again! I really appreciate the assist… looks like I just might be able to get some use out of this!

1 Like

No problem :slight_smile:
Try pressing the bottom right corner (not a corner, it’s a circle, but you know what I mean) of the screen after requesting for adb permission
I don’t have a KW88, but I do have a round watch (Optimus pro) and in that the “allow” button appears in the bottom right as far as I remember

That was actually my assumption, as well… have been trying it, but not succeeding. I have a feeling I just don’t know the sequence of what is actually happening on the screen from boot up to when the dialog appears to authorize the ADB connection, since I don’t even know if the screen is actually appearing!

Also wondering if just the changing of those items in the default.prop are enough to allow it to make the popup appear (developer mode enabled, etc).

As always, I appreciate all ideas and suggestions… Heheh