Kospet Prme SE-watch is not reading sim card

Watch is no longer reading sim card.
it happened previously and i did a reboot and it came back fine.
The only thing i have been doing differently lately is turning phone off while sleeping to save battery.
i tried sim on mobile phone and it works fine, tried another sim card and watch still did not read it. Just comes up with note …please insert sim card.
please help

have you tried cleaning the contacts on the sim card holder in the watch. if the contacts are corroded it maybe just isnt seeing the sim card.


i did give it bit of a wipe with a tissue. still nothing. do you recommend anything in particular to clean it with.
i only bought the watch in June.

You can try cleaning the contacts with a little alcohol. But since you write that it worked fine until you turned it off at night, this will likely not solve your problem. I would recommend a factory reset.

1 Like

it just came back on.
havent tried cleaning with alcohol yet. But will try that next time. Maybe the connections arent great and they may not connect again.
Second issue now with the watch as my speakers are crackling. Have tried some tips from the forum here, with limited success(as it is better but not back to normal)
Might have to bite the bullet and send it back which i am reluctant with time issues and cost.

Hello, I am from Chile, and I have the same problem with the kospet SE, it no longer connects with the operator, a few weeks ago I stopped finding a signal … I tried all the chips and nothing, maybe it’s IMEI but the companies tell me that the device does not have IMEI lock. What can be done, Root …?