Kospet Prime 2 Official support UPDATED!

I have often found this (or similar) occurs, though most times the watch at least shows up on the PC drive list but is merely inaccessible. I figured out how to sort it either way.

Make sure the watch is facing up with face lit up ready to accept touch instructions and that it and the cable connection are firmly supported (to maintain the finicky cable connection when touching the screen). Now connect the cable to the PC and you will see a message pop up up on the watch face confirming the USB connection and including a prompt to confirm the type of data connection required. From memory a couple of the options are ‘photo transfer’ and ‘File transfer’. If you select ‘file transfer’ the watch should then (if not already) show up on the PC drive directory and a window should then open on your PC screen ready to go.

Or (if the window was already showing but the watch directory was not showing) it should now both show and allow access to the watch directory.

I have sometimes found that the PC makes similar prompt requests and have in the past had to set both. Recognising what the problem is can be difficult as the pop up message windows only stay on for 20 or thirty seconds(I’m guessing here). It seems to be a pretty inconsistent issue from what I have seen. Sometimes there is no issue at all (with the same machines and devices)


FYI, I managed to establish 2 way email communications with the support team a week after the watch was delivered and within a few hours had confirmation of receipt, confirmation of dispatch of replacement (with tracking number) and confirmation of paypal account refund.

Very impressive once two way communication was established.

1 Like

Good to hear :+1::+1:
I contacted them and they emailed you almost immediately.
Happy it worked out well.

1 Like

Sad my kp2 still did not arrive yesterday my birthday I thought maybe I will have a bday gift maybe next years

1 Like

today i got my kp2 and this is really awesome watch i can’t see my contacts. i synced with google account but my contact list empty. how can i sync?


Oh yeah! I am off to go and learn how to install it in my just arrived shiny new KP2 (with its clever new preloaded hot button watch faces) and firmware version 1.5_20201210. Oh yeah, Oh yeah, Oh yeah. :laughing:

Is there a video anywhere for dummies on how to do this.
I am starting with a brand new watch and haven’t done anything with it other than setting the language. Not put sim card in yet and not paired with a phone as I don’t have one to pair to.

I downloaded the files to my PC (had to extract them all first as the KP2 wouldn’t recognise their format) then copied them across to the KP2 download folder.
Then tried to open them on the KP2 but nothing will work. I can see all the dll and a few exe files but none will open (format not recognised) There is no file named firmware download. What am I doing wrong please.

Morning . Unfortunately you are way off in your methods . Please read this

And you will also need these

Although its old we also have a youtube video on our youtube section


Thank you. Off to learn now. Haven’t flashed anything for 12 or more years

I had sort of got half way when you posted and was really hoping the tutorial would help me find the scatter file but it simply says “Find the corresponding MT android scatter file in the firmware folder” and I don’t have a firmware folder. I assume the [Prime.II-] file is the “firmware”? but it doesn’t even show up. Where do I find the scatter file please

The .7z file is a 7zip archive. You can install 7zip and unpack it, and then you will see that there is a scatter file inside.

1 Like

Thank you. :grinning:

I installed the .7z file (installed to c:programs) but there is no 7zip archive so going to delete it all and start again using this unzip tool to do the unzipping

I dunno. I have tried starting again and unpacking everything with the 7z zip tool (7z1900-32bit & 7z1900 x64) and have gone through every folder but cant find the scatter file. Still no 7z archive. Where is it “packed” please.

If you rightclick on the zipped firmware, you should find an option “open with 7zip”


You champion. Thank you. Pushing on.

Thank You :+1:
I have time, I have patience, I can wait :wink:
Best Regards :+1:
Stay healthy :crown::mask::syringe:

hello, here is an observation with the new firmware. on the weather update when the time changes to noon , or midnight the time reads 0:01 all the way up to 0:59. then reads normal time. all so, are we in the united states going to read c or are they going to go to f for temperature

Thank you all for helping me work through my ignorance and get to grips with my firmware flash upgrade.

It really is an amazingly comprehensive upgrade. Truly impressive. Unfortunately I had a weeks worth of work dumped on me Wednesday afternoon with a deadline of Saturday, so I haven’t had time to do much more than the reset, load my files and apps, then upgrade them and set all the personal preference settings, so I haven’t had any time to do any proper assessments but omg it is so much better to use now. Thank you.

I have a question that I was going to ask in the request a watch face section but it is particular to the KP2 and it’s not an ordinary watch face type request so I thought I should toss it out for discussion here.

Is it possible to have a watch face within a watch face?

More specifically, is it possible to make a loadable watch face/app that creates a 4mm wide portal/band around the outside edge of a KP2 screen with a half dozen live buttons set into it for apps (phone, messages, gmail, and a few customisable links) with out taking over the whole screen so that it could still be used to host all of the beautiful watch faces you guys make?

Kinda like a stargate portal that can stay in place and provide additional customisable hot link buttons for use around the outside of all watch faces.