Kospet prime 2 fault by using maps

Hi there,

since a while I cannot use google maps.
If I try to set a target than I get a black screen with “Google Play Dienste” written on it.
Does anyone has the same problem.
Another Watch of mine (Lokmat APPLLP Pro) has same issue.

Thanks for feedback

Manually update your Google Play Services and play store.
Check for any other updates after that.
It should be fine after that, but if not then factory reset and then manually update the apps if they don’t update automatically.


thanks Pablo. I tried everything with no change in result.
so I tried the last option to reset the watch.
Serious after reset, that I couldn’t get a google account connection for many hours. I day a later I was able to connect to google.I was not able to get everything run until next day. Strength, that I have the same problem with another watch from lokmat. Next week , I will try to solve the problem the same way. greetings Joe

Where are you located?
I mean which country…?

Did you use this app - it’s very useful. You must make sure that you have set up your time zone and language etc before using it.

1 Like