Kospet Optimus Pro - Camera not working

after one month the camera stopped to work. No shocks or other damage. I’ve tried to reboot, reflash the firmware but none. The camera is dead. Does someone have a similar experience?
Pier Andrea

You can try two things :

  • a reset to factory of the FW (or flash)
  • if not working, maybe the hw is disconnected… that mean opening the watch and check if all is connected…

Thank you Eric,
Ithink that I’ll crefully open the watch…

On the off chance you haven’t attempted it–try a different cam app, e.g. HedgeCam.

1 Like

I’ve solved the problem!
After opening the Watch one connector resulted disconnected (May be completely disconnected after the removal of the bottom cap). I carefully reconnected it and the camera restarted to work. Every function seems to be ok now.
Unfortunatly I did not take some pictures of the internal part of the watch but the good news is that the (huge) battery is easisly accessible and hopfully replaceable.
Thank you Eric for your suggestion.
Pier Andrea.

ps. Thanks also to Tehq for the suggestion. I’ve unsuccessfully tried a lot of different camera apps.


Two days ago the camera problem was again there!!!
And, at the same time, I observed an incredible battery drain!!!
I reopened the Watch and the connector resulted disconnected.
Then I decided to apply a small piece of rubber in the back of the connector to apply a pressure when the cap is closed and screwed.
The camera is working now and the battery life is incredibly long.
Is it possible that the differences in battery life (and temperature increase) among watches could be related to this connector?
I have the 2.7 version of the firmware.
Pier Andrea.
ps: I’ll post some poctures of the surgical procedure I submitted my Optimus Pro.


That’s an interesting feedback. Maybe Kospet could check that. @pablo11


Thanks Eric,
It’s interesting because there is supposed to be a small rubber sponge on the connector - exactly as you described. It is designed to stop this from happening.

It may be that you were unlucky because mine has this…
Thanks for posting this - it will help anyone who has the same issue. :+1:

1 Like

try reverting back to FW v2.5 or 2.6 and you may see significant battery savings.