IQI I3 apps/data sleeping

Hello, still fighting with my I3 to make it useful enough to keep using. I’ve gotten M2D working, but the issue I’m having is that apps seem to go to sleep shortly after the screen shuts off. So if I have the M2D app open and send a test to it, no problem. Turn off the screen and send a test, and also no problem. But if I wait a few minutes after the screen is off, the notification doesn’t show up until I turn the screen back on and open the M2D app. Then any notifications that were sent while the app was asleep suddenly show up. Obviously this is less than ideal. I’ve also noticed that Gmail seems to do something similar, so I’m thinking this is an issue that affects all apps on the watch. Is there some setting that sleeps apps or data that I might be missing? Also I’ve noticed the watch seems to get new IP addreses frequently while on WiFi, not sure if that’s related or not.

Mar 19, 2017 18:15:30 GMT 1 f00bar12 said:
Hello, still fighting with my I3 to make it useful enough to keep using. I've gotten M2D working, but the issue I'm having is that apps seem to go to sleep shortly after the screen shuts off. So if I have the M2D app open and send a test to it, no problem. Turn off the screen and send a test, and also no problem. But if I wait a few minutes after the screen is off, the notification doesn't show up until I turn the screen back on and open the M2D app. Then any notifications that were sent while the app was asleep suddenly show up. Obviously this is less than ideal. I've also noticed that Gmail seems to do something similar, so I'm thinking this is an issue that affects all apps on the watch. Is there some setting that sleeps apps or data that I might be missing? Also I've noticed the watch seems to get new IP addreses frequently while on WiFi, not sure if that's related or not.

make sure that power saving is off in the x3+ in display settings there is an option to leave connectivities on even if the screen is off, locate this.

[/quote]make sure that power saving is off in the x3+ in display settings there is an option to leave connectivities on even if the screen is off, locate this.[/quote]

I do not have a power saving option under display.

Mar 19, 2017 21:39:16 GMT 1 f00bar12 said:

install google gesture and locate power saving power mode and just see if power saving option is on. 
Mar 19, 2017 21:39:16 GMT 1 f00bar12 said:

make sure that power saving is off in the x3+ in display settings there is an option to leave connectivities on even if the screen is off, locate this.[/quote]

I do not have a power saving option under display. [/quote]

Have you tried under “settings/connection” limit data in background ?

Mar 19, 2017 23:20:19 GMT 1 soniasophie9697 said:

Mar 19, 2017 21:39:16 GMT 1 f00bar12 said:

install google gesture and locate power saving power mode and just see if power saving option is on. 

I can’t find an app in the play store called google gesture, is it possible it’s under another name?
Mar 21, 2017 10:40:16 GMT 1 ricktop said:
Mar 19, 2017 21:39:16 GMT 1 f00bar12 said:

make sure that power saving is off in the x3+ in display settings there is an option to leave connectivities on even if the screen is off, locate this.

I do not have a power saving option under display. [/quote]

Have you tried under “settings/connection” limit data in background ?[/quote]

Under Settings/Connect I have “Restrict app background” as an option and it was already turned off.  

Still haven’t found the solution to this. Managed to find a link to google gesture search in another thread here, but still no luck finding the setting I need. It’s frustrating because I like the watch otherwise, but at this point it’s just a very fancy watch if it’s not giving me any notifications.

Apr 12, 2017 16:08:25 GMT 1 f00bar12 said:
Still haven't found the solution to this. Managed to find a link to google gesture search in another thread here, but still no luck finding the setting I need. It's frustrating because I like the watch otherwise, but at this point it's just a very fancy watch if it's not giving me any notifications.

look through all settings and locate where the connectivities are shut down when screen is off, it should be under power saving or display, as long it is marked you wo'nt get notifications when the screen is off.

The only setting I found that comes close was under WiFi/Advanced “Keep Wi-Fi on during sleep”, and I have already enabled that. I will only get new emails when I actually go and open Gmail and the same with M2D notifications only show up for a short time after I’ve opened the app. I’m frustrated that my I3 doesn’t seem able to do this somewhat critical function to being a smart watch.

Apr 12, 2017 22:10:53 GMT 1 f00bar12 said:
The only setting I found that comes close was under WiFi/Advanced "Keep Wi-Fi on during sleep", and I have already enabled that. I will only get new emails when I actually go and open Gmail and the same with M2D notifications only show up for a short time after I've opened the app. I'm frustrated that my I3 doesn't seem able to do this somewhat critical function to being a smart watch.

go to display and scroll down and see if you have the screen off options. it should be there if not use google gesture to get to screen off.