I struck a strange behavior in CSM tonite - whenever I add an

I struck a strange behavior in CSM tonite - whenever I add an array_steps, that is not visible nor is every item added after that. Has anyone encountered that before?

…I should elaborate - I create the watchface including a steps array in CSM, and in simulation mode it appears to work fine, but when I transfer to my Finow X5 everything after and including the steps array is not visible.

Sometimes too many layers and functions can make it difficult for the watch engine to cope… I’m guessing that your “perfect” watch has every bell and whistle :slight_smile:

@Andrew_Davis ​ I’m known for not doing things by halves :slight_smile: - I created a date using the format “MON 01 JAN 2000” that uses 4 arrays; I’ll look at the other options to create that tomorrow… Cheers.

@Chris_Wilkinson That is my preferred format too… :slight_smile:

I can confirm that I can add a pile of arrays and rotates, but when I add an array_steps anything listed below the array_steps is hidden - its array type 12.The thing that is strange to me is that the XML is the same as all the example faces that have steps that work fine on my Finow X5. The order of objects I’ve added is background face added first, arrays next, then rotating hands last. I’m using CSM, and developing 400x400 faces for the X5. My X5 has firmware 160524, and is working as expected - faces supplied with the watch, or developed by people in this forum, that have steps are working fine. I must be doing something wrong? :slight_smile:

How about… are you adding the wrong set of characters to the array_steps… or is there something not correct about the character set?

I think that I’ve seen array_steps character sets with “zero” twice…

I was facing the same issue. It was solved by adding the number 0’s image tag in the steps.xml file after the number 9’s image tag. e.g. steps_array_num_0.png

@Andrew_Davis - at what stage of the process would I get the wrong set of characters? As you can see from the screenie below the problematic face is quite simple, only using a few layers. I initially used the array generator to create the PNG graphics I needed to make a set of orange LCD numbers, but I have overwritten those originals with lovingly hand-drawn ones to create the orange LCD text. I then found that CSM does not like multiple arrays using the same set of PNG’s - since I have 3 arrays all using the exact same graphics to create orange LCD numbers, I edited the XML’s for those 3 arrays to point to the same set of PNG’s - CSM didn’t like that, and made fresh sets for each array that uses them. So I have num_0.png that I created, but now also have num_0_1.png and num_0_2.png that CSM has created by copying and appending _1 and _2 to the filenames. If I decide to change the colour of the LCD numbers it will become a slow process to update 3 sets of numbers. I’m still confused why adding a steps array hides anything listed after it. One thing I haven’t messed with is clock_skin.xml - I notice in the examples that came with CSM there is a lot more stuff in there, including Japanese and XML tags not present in any files I’ve generated.
missing/deleted image from Google+

Hi @Jiten_Kanani , I tried your suggestion but that didn’t solve it - seems that anything I add after array_steps is hidden - I’m wondering if this is a specific problem with Finow X5? I will look at this again tomorrow…it is 1:10am and my alarm clock doesn’tr care that I am not asleep yet! :slight_smile:

I had problems on a watch with steps (and temp and battery level) when I used CSM to re-size a character set that I had made… I thought that as I wanted to use the same font (style) for several different purposes and in several different sizes, that I would make a big (150 x 80 px) master version and just use CSM to resize them in Properties>Width/Height… it didn’t work out well… all the arrays were there but the size and proportions of the characters was all over the place!!!.. no short cuts I’m afraid :slight_smile:

Your watch looks very straight forward… . I’ll quickly make something similar… we can try it on our watches and compare notes (I have a D5) :slight_smile:

I’m sure that you’ve heard of Houdini, Copperfield and Paul Daniels… well prepare to be amazed - astounded - and perplexed…
Andrew the Omnipotent has saved the day…

Thanks for the example clockface @Andrew_Davis - I managed to get my face working by using the exact naming schema you have used on the one you sent through. When I initially setup mine, I created graphics using the array generator, but renamed some PNG’s and used my own names for the XML files - maybe CSM is fussy about filenaming? I also noticed that in your steps_array.xml there is an extra entry for num_0 after num_9, so @Jiten_Kanani was on the right track. The face works fine now. I’ll finetune that and some others and share them one day - once I’m happy they look half decent… Cheers. :slight_smile:

@Chris_Wilkinson Good work… :slight_smile: