I need help 1.5 update lemfo lem 8

My watch has stopped on lemfo logo, and it is not working on update 1.5, I installed update 1.3 and the problem still remains, I did not get the update 1.5, can anyone find a solution to my problem and thank you

Whitch version is your watch? 1/16 or 3/32?

Does anyone have an update 1.5?

1.5 is 16Gb, I think. Your watch might be a 3/32 version. Try this one:

You have to use the “firmware upgrade” option in the flashtool.

I have a version 16 and 2 RAM

Please use firmware upgrade" option.

I guess it’s the newest version, but I will have a look…

Thank you, the problem is still there, stop on the lemfo logo, I wish I could get the 1.5 update for the 16 GB version

I’m quite sure there isn’t any. @pablo11 , can you confirm?

Did you actually flash the watch as @G1NT0N1C said ?

I will see what I can do.
Give me a couple of days because I can’t see properly at the moment.
But I think if it is possible I will be able to let you know tomorrow… Hopefully.

1 Like

@Lazio_Ali again - my apologies for the delay.

This is the 2gb ram + 16gb storage firmware.
I just got it from the solution provider server.

When you extract the contents - make sure there are no spaces in the folder name.
Just to show that it is the 16+2 version - this is how we have it stored on the server and I removed the brackets so that the flash tool will recognise the folder properly.

1 Like

It like the old saying "If your in trouble & you can’t find a Policeman to ask for help…well then ask @pablo11 "!! :woozy_face: :crazy_face: (Well it goes something like that anyway! :rofl:) I love the way everyone jumped in to help out here! :+1: :+1: Cheers, “Can you get a speeding ticket dropped for me please Pab”?!! :woozy_face:, Doons

1 Like

Maybe, who issued it and when? :joy::joy::joy:
lol, sorry mate - I don’t think so :grin:

1 Like


I have a box full of Lemfo Lem8’s that have been used for some research project for sports but the firmeware seem to have been changed. So I want to bring them back to stock levels and I tried to load a lemfo lem8 firmware but this kind of bricks the watch. According the windows usb connect/disconnect sounds it seems to be in a bootloop after flashing the firmware that I have.

So I browsed through this forum to look for fimware.
I tried:

  • Z29-LEM8-V1.3_open_with-7zip.7z
  • Z29-LEM8-V1.4_3+32.7z
  • Z29-LEM8-V1.5.zip

All of these brick the watch into a bootloop. And then I cannot load new Lemfo firmware. I was able to load Kospet Optimus Pro 3+32 firmware. At least spflash starts and finishes the download. But this firmware does not boot either, it shows a Kospet logo and then nothing happens. But loading the Kospet firmware makes it possible to load another Lemfo firmware. It’s my own unbricking trick.

The boxes tell me that it is the 3+32 version of Lem8.

I was told that @pablo11 is the #1 guru here regarding Lemfo firmware. I am happy to send one if a fix is provided!

Make sure to use the latest flash tool and USB drivers. I’m quite sure that it’s a driver problem.

As discussed via PM. I will clarify it and inform you. :+1:

1 Like