How to root lemfo lem x

I have issue with imei number so please any one can help me in how to root lemfo lem x or lemfo lem 10

what a confusing post… :thinking::face_with_raised_eyebrow:

edit: I see now all ties to LEM 10 have been replaced with references to LEM X; now it makes sense!

2 Likes

@Parth_Myatra, follow the steps in this thread: https://discourse.fullandroidwatch.com/t/twrp-for-lemx/36068, and then transfer the magisk zip to the watch and install that as well

Can u guide me on video call , I never Rooted any thing before

sorry, I don’t do video calling.

btw, if you do successfully root it, I won’t be able to help you fix the imei number

Then how to fix SIM card issue in lemfo lem x or lemfo 10

I could use some help with my Lem X. I am not new to rooting. I have rooted several Android phones but never an Android watch. I followed the instructions on installing twrp with sp flash exactly. It downloaded successfully ( I got a green check on the PC screen. However, when I disconnected the USB and went to start the device, twrp did not start automatically. In fact, it just displayed the LEMFO splash and went blank. I tried several times and that’s a it will do. I then tried to reflash the stock rom but after clicking download (upgrade rom) and connect USB it won’t start the download/ flashing process. Any suggestions would be greatly appreciated.

I was able to flash back to stock by repeatedly holding the power button while sp flash was ready to download. At some point, I hit the sweet spot and it started flashing. It now boots and functions correctly. However, I still don’t know what went wrong. It’s like the twrp image is incompatible with my device or is it something else? Anyone have any thoughts or suggestions?

@Symblex, which download mode did you use when flashing twrp?

Download only

1 Like

that’s good, then I don’t know what could be the problem.

Maybe there was a problem during flashing that wasn’t detected or maybe the downloaded files was corrupted. My best suggestion is to download the files anew and try to flash it again

2 Likes

Ok, I’ll do that soon when I have some extra time and post how it goes.

Success! I downloaded everything again and ran SP Flash as administrator as a precaution. After reflecting on how I did things the first round, I believe I know what caused the corruption. I made the mistake of unzipping with the Windows unzip utility. I should have known better as I have read how it can corrupt files. This time I used 7-zip for all archives. I strongly recommend not to use the Windows unzip utility for any files as critical as these!

2 Likes

Hi . This is a english only speaking forum . Kindly edit your post or i will have to remove it . Thanks

1 Like

@Symblex Can you help me please I want to root my lemfo watch

Sp flash tool
Database
Image

This all stuff Dowland from lemfo official website
Still I am getting this error

You don’t seem to have all the necessary items downloaded to root. It’s not a rom image–it’s an image of a custom recovery as well as a root manager. I’ll check and see if I have the links saved for what I used. The download comes with explicit instructions and I can clarify some items that aren’t clear. I’ll try to get back later tomorrow.