Hi I did an advanced wipe (dalvic cache, system, data,

I did an advanced wipe (dalvic cache, system, data, cache) in recovery because my bluetooth turned off all the time and i got a boot loop. Anybody knows how I go into recovey with hardver keys?
I use Imperium W812a v1.2.0 rom.

You can do it using MTK Droid Tool in windows. With it you can reboot the watch on recovery mode but before you must have checked the usb debugging option on the developer options.

Right lokifish. I didn’t read all the post… Why did you make a wipe to the system and data partition??? You need to flash the firmware again…
Of course with the firmware installed you can use the tool instead the physical buttons.

I did a wipe because my watch throw away the bluetooth and the wifi signal many random times, or the signal was too low.
I tried the SPTools, but nothing happened.
USB Vcom drivers installed,but the PC did’t communicate with my watch.
I think, I need to start recovery how i can restore the rom from the watch.

Make sure all your pins are connecting in your charging dock as well. That one almost bit me.

I tried three computers and many USB ports but nothing happened. I tested all pins on the dock and they were okay …

I start SPFlashTool, use the scatter file and push the download button. After that I connect the USB cable. The watch screen turn on and the charger symbol is appear on the screen. At this point I wait a lot, but nothing happens.
SPTool doesn’t do anything just wait for a connection.

The watch screen turned on? I’m not sure, but perhaps your watch wasn’t powered all the way off?

No, I removed the battery connector and then plugged it back, so the phone was switched off. I did everything as it was in this video. (https://www.youtube.com/watch?v=gS55s0OMmao) I think that my PC doesen’t detect the watch USB signal, or the watch doesn’t send USB signal.