hi, a newbie, and not a geeky from the far east (manila).

hi, a newbie, and not a geeky from the far east (manila). been following threads here. got my new x5 which should have a companion medicine with it (for the headache, hehehe!)

-first i was not able to get notifications (sms, email, social apps) from my iphone except calls, been looking for an appropriate app for the last 6 days but no success!

-then 2 days ago, i installed some skins (varth vader) and presto! blank screen! i emailed both finow and the seller for instruction but to no relief. and just today, i read a similar trouble with x5 from one of our fellow member here.

-apparently, the solution would be to flash the firmware as Ms. sonia suggested. I am searching for the link of the firmware for hours because the link our good friend with a cool voice from smartwatchticks led me to this “w815_kk.logoswitch.common.72kk.emmc.160524-034208” (pic enclosed) which is not opening or somewhat different from that shown in the youtube video.

As i said, im not a geeky type, and i feel like il be breaking any moment! is the link above correct? why then the folders are different as shown in the pic? and what will i do so that notifications will be pushed to my dear, all mighty, and ever brilliant X5? Please help… Many thanks in advance.


“Our good friend with a cool voice…” … Excellent :slight_smile:

Sorry I can’t help with the answers but other will… you could also try the FAQ and “search bar” on the forum homepage…

thanks Andrew! you probably know who he is. on this part of the globe we are just hearing his cool voice. nyehehehe!

Mr Cool Voice = Mr Ticks = William…
PS… I was in Manila in February :slight_smile:

From the so called Mr Ticks himself :slight_smile: - https://plus.google.com/+SmartWatchTicks/posts/PUawqM5FvdA

really, thats cool andrew! you should try visit palawan too, very nice there… mr. ticks = william, “greeeetings!”

Pablo Eleven, thanks for this link!

@Arnold_Lira We visited… Puerto Princesa, Palawan… Boracay and Manila… we had a great time :slight_smile:

Very very nice!

And i havent solved my x5 issue yet… :joy:

Oh my goodness. Gotta read every post these days! Never know what might be said. :slight_smile:

no offense meant.

Oh, no problem. Had me blushing…

can hear it from here… nyehehe

@Arnold_Lira so you flashed the firmware from here on the community in the correct firmware section, after watching this how-to video, and it still doesn’t work?

@SmartWatch_Ticks As they used to say in the old days, “He has a marvellous face for radio…”

i was there to the point of scatter files was ready for download (flashing), but my x5 was not recognized by the pc although the battery was charging. i had to disconnect and try the other usb slots. i never had it connected. then came the dialog box saying some diagnostic mis spell.

@Arnold_Lira try a different cable.
Many cables are no good and a real pain in the bum.

when x5 is off, it says “one of the usb devise has malfunctioned.” and the x5 does not appear in “my Computer” but when i turn the usb on while the watch is on, the watch is recognized.

@Arnold_Lira then you need to use USB deview and remove the VCOM driver you have installed and install it again.

@Pablo_Eleven_Pablo11 i got the splatter running again and the x5 was successfully recognized by the pc but it seems its not downloading. its been more than 25 minutes and not a byte was downloaded.