Hey All, I have just baught a D5 by no.1 smartwatch.

Hey All,

I have just baught a D5 by no.1 smartwatch.
I am facing 2 serious issues:

  1. Can’t connect phone to my PC, no matter what driver I installed, always getting unrecognized usb device notification.
  2. I have inserted a SIM and cannot add an APN, so I can send sms and make calls but cannot use data connection.

Can someone please assist me?


Are you using a usb 3 port? Does the watch show any notification?

Hey Matan,
Thanks for helping, I am using a usb2 port, watch is showing a charging notification.

OK made some progress.
Original charger probably was faulty.
I am now able to see the device on my PC.
Now when trying to follow instructions for firmware update using flash tools (instructions on official site) after choosing the scatter file and pressing the download button, I connect the device powered off as requested and nothing happens, update does not start, request to install driver does not appear. Any clue on what I am doing wrong?

Open the device manger before you connect the watch-after you press download, then connect it. What do you see?

If watch is powered on I get a new drive in Portable Devices.
If I enable usb storage on the watch I get W806 in the Portable Devices.
If watch is powered off, I get nothing new in the device manager.

Find me on facebook, we’ll try to figure it out in hebrew…

When you get it figured out, can you post what you did to get it working here in English to help out others? Thanks!

sure, working on it

hi mor
i had the same APN issue and solved it .
let me know if you need help with it

I have this issue with an IQI I2 smart watch that just arrived today. I need to add an APN, but there is no add button available. Tried looking on Play Store for an APN editor app that would work better with my round display :slight_smile: Still no luck!

hi mor
i had the same problem and solved it twice
try to flash the latest rom from no site
that fixed my second time
if its not working for you let me know and ill try helping you the long way

Will this ROM work with the IQI I2 smart watch? I downloaded the latest firmware update posted in this Community area for IQI I2 but still can’t add a new APN…

im sorry i dont know this watch