HELP PLEASE! I have a problem with my barely new KW88.


I have a problem with my barely new KW88. Yesterday I remained without battery! So the watch died. Now IT WILL NOT CHARGE… at all… or boot or anything.

Did this happen to anyone? Do you have any suggestion?

I really like this watch and it sades me to see it die like this after only one month or so :frowning:

try other charger and wait some time… if not work I think you can try open back and disconnect and reconnect again battery cable.

@Al_Rod do you have any idea where I can get another charger cable? The charger I tried several… iPad charger, iPhone charger and universal charger. Non works :frowning: Maybe the charging cable is bad. But I have no idea where to get another charging cable

@Cristian_Sallai another charger (maybe a laptop usb port)… not cable :slight_smile:

@Al_Rod I tried that! :frowning: It did not work! :frowning: Do you have any idea how hard it is to disconect the battery?

I had a problem with the charging base for my x5 and it turned out one of the small metal prongs had come out. I used a small piece of copper wire as a replacement and it charges fine. I’m not familiar with the KW88 but have a close look at the charging base and see if there’s anything obviously wrong with it. Try a different cable and see if it makes a difference. Good luck

@Cristian_Sallai ​ if you need a new charging cable check here

I have the same problem. I noticed a crack on the back plate that is keeping the pins in the plate from conducting all the way through. I found that pinching the charging cable tight to the whole watch, it starts charging. Since mine is 4 weeks old, I’m returning for repair/replacement, hope this helps you.

@steve_rochat1 well… mine is I think 6 weeks old… but it would be hard to return. I will also check the cable. There is a design flaw on it. in the sense that since it is magnetic it sticks to anything metal. Once it was stuck to a metal part while it was pluged in and it was really hot. I will check the pins and cable again and eventually if I find one, get a new cable.

If not, disconnecting the battery will be the next step

so… I just want to come with an UPDAT!Ș Yes,… it is the cable. It has a loose cable from one pin. I will solder it today. I managed to put it in place and fully charge the watch.

Thank you guys for teh suggestions. I am happy to have my watch back!