Heart rate monitor not working anymore

Hey guys,
I do not frequently use the HR monitor.
But I tried today and got not results.
No light shows up during the measurement, so I wonder if something went wrong.
Any idea over the possible cause(s)?


It could be a disconnected cable. But you can try to reboot, also reset to factory…


After further investigation : hours needed for GPS fixing, and still no HR since the installation of the firmware TICWRIS (system only) on my LemT.
I used GPS fixer apps -> no effect.
Factory reset -> no effect
Anyone using TICWRIS firmware above the LemT has seen problems on that matter?
If I need, let’s say, 2 hours for GPS fixing, how is it supposed to get better afterwards?

I have flashed my Lemt T with the Witwris firmware and can report that both GPS & Heart rate monitor work fine for me.

For some reason though the built in weather app for the Ticwris is reporting me as being somewhere I am not even though Google maps and Google weather both report the right location.

Also the alarms function of Google Clock no longer work & I prefer them over the built in clock app as I like to use the Google Assistant Routines

Problem GPS solved by switching back from TICWRIS firmware to LemT V1.4.
The link was obvious : after flashing, the GPS caught the signal without problem.
The GPS is working fine for @TremF with TICWRIS (And so many others I guess), so it remains a mystery, why it didnt work to me…

Have you only flashed the system image of ticwrist or other files ?

@Eric_Crochemore system.img only

So yes, that’s strange. Maybe you could try again to flash…

1 Like

edit : problem fixing GPS comes again. Whatever the firmware. I tried to clean up the inner parts of the strap… I’ll now see if something changes…