Google Calendar doesn't function

I can’t get Google Calendar working on Kospet Optimus 2. No matter what I do it always crashes on boot. Is there any remedy? It asks for calendar permissions then crashes

Someone mentioned the need for Google’s system app, “Calendar Storage” so I sideloaded it since it wasn’t pre-installed, and didn’t fix the problem but asked for contacts permission. I have a lemfo LEMT and never ran into problems.

Any help would be appreciated.

It is a issue . However when the new FAW firmware is released on this forum it works just fine :+1:



In stock firmwear of Android10, we can’t use some Google apps. Google calendar, Google contact, Google translator, Android auto, etc.

I use third party apps. One calendar (its need some money) is a alternative apps of Google calendar. Its not best solution, but in full android watchs, I can avoid the problem by using other apps.

International FAW firmwear is best, of course.


1 Like

Still doesn’t work till today…
And One calendar seemed to be good but I can’t get to make it work and remind me any events by itself after a few minutes. It seems that it doesn’t work well on second plane.

Have tried you tried this to get " one calender " working in the background ?

1 Like

Yes, of course. I’ve tried all already.
When I do some test, it works fine on the moment, but if you have an event scheduled on a longer period, is a fact that the program won’t remind me anything when the time comes.

1 Like