Flash error

Hi all,

i have a zeblaze thor and today i tried to flash last firmware but… by mistake i flashed the lemfo lf 16. When i turned on the watch display is black and i cant see nothing.

Now i can not flash the right firmware because the watch is  on and the flash process dont start.

What i can do?


Aug 9, 2017 15:38:24 GMT 1 minds said:

that is a problem because most likely the preloader was marked, you have to disconnect the battery or wait till it drains itself and flash the right rom, do'nt flash an update but the stock firmware rom.

Normally keeping the button pushed for a minute or two will turn off the watch. So, connect it, start dowload, and push button till it starts.

I waited until battery drains and then flashed,


I have similar problems, I get an unknown peripheral is connected and not flash the rom the watch vibrate if old button for more time the sensor in the back flash, but the display stay black

Either wait for battery to drain or disconnect battery for a while then reconnect and flash again with proper firmware.
Remember that you first click on Download button in SP Flash Tool and then connect watch to computer

solved i have trash it!! this is last china watch for me !! only scam!

Well next time before you trash something like that poke me I’ll gladly act as a trashcan :wink:
From my own experience I know that’s not that easy to hard brick those watches.
Did you try doing what I wrote?

Aug 20, 2017 18:22:48 GMT 1 nenno said:
solved i have trash it!! this is last china watch for me !! only scam!

nameless right, what is your model?